Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

FileUpload and

I have downloaded and installed Vanilla on a CentOS 6.5 box
It is running in a subdirectory under the document root and I am currently accessing it via IP ( no hostname, no SSL ).

Pretty urls, e-mail, all the basic stuff is working.

What I cannot figure out is getting File Uploads to work.

I downloaded the FileUupload plugin from
I extracted the zip file into the plugins directory and set the permissions and owner/group the same as the other plugins.

However the plugin does not show up in the list of plugins in the dashboard nor do I have a "media" menu under "Forum Settings". There are no "attachment" or "upload" permissions in Roles & Permissions.

As per other forum posts I have double checked the permissions of the directory and all sub-directories and files inside plugins/FileUpload and they match the other plugins. Also APC and GD are installed.

Enabling the WYSIWYG edit ( cleditor ) plugin works.

What am I missing?


  • try /utility/update and /utility/structure.

    I have double checked the permissions of the directory

    have you also checked if the ownership of the folders is the same as the other plugin folders.

    also see:

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • lancellancel New
    edited April 2014

    @peregrine said:
    try /utility/update and /utility/structure.

    I am not sure what you mean by this. Not that familiar with Vanilla.

    I have checked that all of the directory permissions are the same as the other plugins.

  • lancellancel New
    edited April 2014

    Ah, found it further down on the page you linked

    I ran the structure scripts and there were no errors.

    The update results in a Bonk.

  • The update bonk was due to a missing Smarty compile directory, created that and the update ran without error.

    Still no FileUpload in the plugins list under "Manage Plugins"

  • I also just ran an "inotifywatch" on the FileDrop directory and on the cleditor directory. There was activity on the cleditor directory when I reloaded the plugins page but not activity on the FileDrop directory so apache wasn't even reading the directory. Is there a cached list of plugin directories somewhere?

  • lancellancel New
    edited April 2014

    Disabled SELinux, now it shows up

    you can use "ls -Z" to see the SELinux security context information

    I had to do

    chcon -v --type=httpd_sys_content_t FileUpload/

    to get it to play nice...or at least show up,

Sign In or Register to comment.