Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Warning: Wrong datatype for first argument ....

edited July 2006 in Vanilla 1.0 Help
Warning: Wrong datatype for first argument in call to array_key_exists in /home/sites/site4/users/ct/web/forum/library/Framework/Framework.Class.Delegation.php on line 50 I have just installed the forum and I have this at the top of the settings page. Also i get similar errors when i install extensions. The server meets the requirements and i've set the permissions. Any help would be greatly received! cheers Phil

Comments

  • Options
    MarkMark Vanilla Staff
    First of all, make sure that all of your files have been uploaded properly.
    The most common problem lately has been that files get garbled during the upload.

    If that doesn't fix the problem, come back to us with more information. What version of php do you have, for example?
  • Options
    everything is uploaded and i uploaded with Automatic preference not Binary. http://www.tech.port.ac.uk/ct/forum/phpinfo.php Is where the info on the server is. I think it meets the requirements. php: 4.2.1 and mysql: 3.23.39 ive set read/write permissions for conf directory
  • Options
    still get the error message to do with framework.class.delegation under the settinsg tab
  • Options
    i am getting this error as well, please advise.
  • Options
    MarkMark Vanilla Staff
    Do you have any extensions enabled?

    If so, disable them all. Then enable them one-by-one, checking for the error after each one.
This discussion has been closed.