Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Locale text changes not working

I am trying to make some simple changes to text like Howdy, Stranger. I followed the instructions in the docs, but the changes are not showing up. I suspect I am not changing the correct files or I have them in the wrong directory. I created a locale called torahrx and placed the captured.php, captured-admin.php and definitions.php files in the subdirectory /locales/torarx. Here's the definitions.php file:

<?php if (!defined('APPLICATION')) exit();
/** This file was generated by the Locale Developer plugin on 2010-11-23 12:23:07 **/

$LocaleInfo['torahrx'] = array (
'Locale' => 'torahrx',
'Name' => 'TorahRX Locale',
'Description' => 'All of the text in a default Vanilla install.',
'Version' => '1.0.1',
'Author' => 'Rabbi DuBrow',
'AuthorEmail' => 'rmeilech@torahpractic.org',
'AuthorUrl' => 'http://www.torahpractic.org',
'License' => 'GPL2',
);

In the capture.php file, I modified:
$Definition['Howdy, Stranger!'] = 'Hello, Friend!';

I did clear the cache .ini files after making changes.

Any suggestions would be greatly appreciated.

Comments

  • vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited April 2014

    what is the name of the language file you are using? I am not sure that is a valid language name.

    check in you config to see if is in there. So the locale is here?

    forum/locales/torahrx/definitions.php

    for example if it hebrew vf_he_IL that would be the locale name. The language hebrew Israel . vf_he_IL would go in the configuration as the locale just as en_Ca is english

  • Here is how it is in config : $Configuration['Garden']['Local'] ='torahrx';

    That is how the folder is named in the locales subdirectory.

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    What language is it ? where did you get it ? The language needs to be specified as I explained above. That has to be the name of the folder where it is stored.

    es_Es spanish , hu_Hu hungarian etc. I am not sure if it can be any name or if it has to have the language tag in the end. That may be why it is not working.

  • OK, I think I got it. A typo: it's supposed to be $Configuration['Garden']['Locale'] ='torahrx'; not 'Local'. Thank you for pointing me in the right direction. Totally off topic, but since you have been so helpful, do you know anything about Firefox problems with Bootstrap navbar?

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    If you created that local to keep you own definitions you changed like howdy stranger but you are using english the default language, then you need to create a folder called locales and add it to your theme folder.

    Then all you do is put the definitions file in there if it is just english things.

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    No sorry I do not know about firefox and bootstrap problems :(

  • Sorry, not sure I understand. I enabled torarx and saved in the Dashboard. With the above change 'Local' to 'Locale' everything seems to be working. Are you saying that in addition to the above, I need to add all of the above to my torahrx themes folder? And yes, all of the changes are simple English, or transliterated Hebrew.

  • vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited April 2014

    If you are using english as the language and want to add definitions in english or any other language you can do it like I suggested .

    If you want the whole forum to be in another language, which will change the dashboard language too, then you do need to add a language locale where you added this one. Only if it is to change the entire forum language.

    For small stuff but to also keep the english in the dashboard use the method of adding a locale folder to your theme and the definitions inside that.

    Then in the theme's about.php where it has the themeInfo

    add

    'HasLocale'=>TRUE;

  • Great. Thanks for all the help. Have a restful weekend.

Sign In or Register to comment.