Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

[Solved] Latest Vanilla - can`t look main page

LusekLusek New
edited May 2014 in Vanilla 2.0 - 2.8

I install new latest stable version from this site in root of my domain, and after installation i success redirect to dashboard, and i can change any settings, but when i go to the main page, i look "

Something has gone wrong.
We've run into a problem and are unable to handle this request right now.
Please check back in a little while.

"
mod_rewrite work correctly. Apaches log hasnt errors. Dashboard work good. WTF ?

Comments

  • Options
    peregrineperegrine MVP
    edited May 2014

    which version number are you using?

    and read this if you are using 2.1

    http://vanillaforums.org/discussion/26685/vanilla-2-1-stable-released

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Options
    LusekLusek New
    edited May 2014

    login, discussion, profile,register not worked too
    Only dashboard and different dashboard settings pages work
    May be exist way to enable debug mode for vanilla that can show errors

  • Options
    peregrineperegrine MVP
    edited May 2014
    • Delete the files /themes/mobile/views/discussions/helper_functions.php AND /applications/dashboard/views/default.master.php (not default.master.tpl which should also be in that folder)
    • Delete the value $Configuration['Vanilla']['Views']['Denormalize'] = TRUE; from /conf/config.php if it is present, unless you are knowingly running memcached and have configured it. If that value is not in your config, you have nothing to do and may continue.
    • Run /index.php?p=/utility/update to update the database. It may take a while. If it fails, run it again. It picks up where it left off if it doesn't complete due to a timeout.
    • Set $Configuration['Debug'] = TRUE; in your conf/config.php to reveal full error messages. Remember to remove it when you are done.
    • Clear your browser cache and cookies, then restart your browser.
    • Clear *.ini files from the cache folder.
    • Revert to the default theme. You can do this manually in conf/config.php by setting the $Configuration['Garden']['Theme'] value to default.
    • Disable plugins. If you cannot get to your Dashboard, you can manually delete lines containing EnabledPlugins in conf/config.php but do not remove HTMLawed's line.
    • Try running /utility/update again (see upgrade instructions).

    or re-read

    http://vanillaforums.org/discussion/26685/vanilla-2-1-stable-released/p1

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Options

    well, after this steps a can`t singin into dashboard too
    It was Upgrade instructions, but i install clear new version

  • Options

    I remove config file, clean database and install again
    All settings - as default, but main page and other forum pages not work
    File permission on files 644 folder 755 but uploads cache and configs - 777

  • Options
    peregrineperegrine MVP
    edited May 2014

    other forum pages not work

    then add this

    Configuration['Debug'] = TRUE; in your conf/config.php

    and tell us what your error is.

    if you still get this page.





    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Options

    may be troubles with php? my php verison 5.4

  • Options
    peregrineperegrine MVP
    edited May 2014

    see this comment. and answer it if you can.

    http://vanillaforums.org/discussion/comment/207459/#Comment_207459

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Options

    well i got error!
    Could not find master view: default.master*
    The error occurred on or near: /var/www/xxx/data/www/site.ru/library/core/class.controller.php

  • Options
    peregrineperegrine MVP
    edited May 2014

    did you delete the default.master.tpl file - if so reinstall it.

    Delete the files /themes/mobile/views/discussions/helper_functions.php AND
    /applications/dashboard/views/default.master.php
    (not default.master.tpl which should also be in that folder)

    this means DO NOT delete the default.master.tpl

    (not default.master.tpl which should also be in that folder)

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Options

    Yes, Now i can see all pages

  • Options

    Thank you

  • Options
    peregrineperegrine MVP
    edited May 2014

    glad it works for you now.

    Remember to remove this line

    $Configuration['Debug'] = TRUE;

    from your conf/config.php

    when you are done for security reasons.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Options

    of course

Sign In or Register to comment.