Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Google Sign-In dosen't works!

AbhinavGAbhinavG New
edited May 2014 in Vanilla 2.0 - 2.8

I am testing it against latest stable release(2.1) and while using

google sign-in plugin (Allows users to sign in with their Google accounts. Requires ‘OpenID’ plugin to be enabled first. Version 1.1|Requires: Vanilla Version 2.0.14, OpenID Version 0.1a|By Todd Burry)

it shows follwoing errors:

Is it broken? And on the other hand , is their any other alternative available as it has been marked with Vanilla Version 2.0.14 compatible.

Even after the screen as shown in image , it never connects with same error. It does shows a password field below username after another attempt , still dosent gets connected.

1.png 8.8K

Best Answer


  • BTW , does this site uses SocialLogin plugin? [the one with LoginRadius]

  • AbhinavGAbhinavG New
    edited May 2014

    @R_J , okay it dosen't works again , maybe i was on a non-sleep mode for days. That made me accept that answer sorry! Same thing happens. Infact now password field comes for a sec and then just goes away!

    Should I get the whole master branch to test instead of 2.1?

  • @AbhinavG said:

    @R_J‌ , Now another wierd thing happened. It suddenly worked when i closed my modal box and clicked on icon again. But when I signout from forums and then from google , and tried my different google ID , it logged back to my same ID :neutral_face: , I tried logging out again and tried with third google ID , it logged with same account it had associated with first :neutral_face: .
    Does vanilla stores some kind of IP adresses with respect of different ID's?

  • More info : It works fine with the master branch on the github , and the icons are changed from the previous vanilla 2.1 version. It accepts different google accounts and creates different forum accounts for them.

    No my concern is , IS the Master Branch stable enough to host forums?
    It seems same as 2.1 .. somewhat to me! And i need social logins for my forum , so I cannot use 2.1 till the bug is fixed.

  • AbhinavGAbhinavG New
    edited May 2014

    Master version has Discussions broken for me. :( So much broke lol

    You can clearly see the difference.

    Note the unanswered category.

  • peregrineperegrine MVP
    edited May 2014

    your on the wrong path my friend - attempting to use master version of vanilla on your self-hosted site as mentioned many many times.

    you should try to identify the problem between 2.1 and master differences related do to the or what is causing the 2.1 version of plugin to fail.

    to get it to work in vanilla 2.1

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • AbhinavGAbhinavG New
    edited May 2014

    @peregrine‌ , I have tried both Master and 2.1 in each scenario. Master does works with google sign-on but breaks with discussion. But that's completely fine as it is in active development state.
    2.1 stable version dosen't works with google sign-on , all is fine. I tried to understand both version of plugins.

    I tried to incorporate master version of google sign-on into my 2.1, but it produced a blank website under the blue header (in default theme). Everything except header wasn't invisible. Now I'm just tinkering with the code of both versions.

    One thing i noted was , earlier versions eg. 2.1 contains design folder inside that plugin , while master branch dosen't. Although this should not create a problem , but might be the disappearance of whole site except header might relate to it? IDK

  • R_JR_J Ex-Fanboy Munich Admin

    I use Vanilla 2.1 (and you should use that version, too), OpenID 1.0 and GoogleSignIn 1.1
    This combination works for me.

  • AbhinavGAbhinavG New
    edited May 2014

    A temporary solution : I compared two plugins and found out a notable diffeence. Add this function at line 116 of file class.lightopenid.php

    protected function fix_url($url) {

    // Fix a malformed return url.

    $urlp = parse_url($url);

    if (isset($urlp['query'])) {

    parse_str($urlp['query'], $query);

    $urlp['query'] = http_build_query($query);

    $url = "{$urlp['scheme']}://{$urlp['host']}{$urlp['path']}?{$urlp['query']}";


    return $url;


    and find a code near line 630 that looks like
    if ($this->data['openid_return_to'] != $this->returnUrl) {

    and replace it with :

    if ($this->fix_url($this->data['openid_return_to']) != $this->returnUrl) {

    there are other differences in the other file too , but I think they are just contributing to visual part of plugin. So no need.

  • OpenID auth request contains an unregistered domain:

    Am getting this error... I am a newbie to using vanilla forums... how to resolve this?

Sign In or Register to comment.