Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Cant Disable Word Count?!?

This discussion is related to the Word Count addon.

Hello,

So I installed Word Count...then I realized I wanted to disable it due to not being able to post a large thread. So I went to Disable and it still remains enabled?? I then tried physically removing the plugin files from my host and it is still not allowing me to post larger posts....What do I do???

Comments

  • Max Comment Length - this thread should be named - How do I change Maximum Comment length.

    word count has nothing to do with larger posts. it just indicates the count.

    you can change the max characters in message from the dashboard.

    click on floodcontrol from left panel.

    it will change or add this to your config

    e.g. 8000 characters.

    $Configuration['Vanilla']['Comment']['MaxLength'] = '8000';

    @carsenk
    you shouldn't leave threads lingering. did the solution work for you. here.

    http://vanillaforums.org/discussion/26916/moving-van2shout-using-bootstrap-darkly#latest

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • peregrineperegrine MVP
    edited June 2014

    @carsenk @kasper

    the reason why you can't disable wordcount. is because the folder extracts to wordcount.

    Yet the plugin info states $PluginInfo['WordCount'] = array(

    the informations in $PluginInfo ['WordCount']

    must match a folder named WordCount

    However, since the plugin unzips into a folder name which is lower-case wordcount the plugin can't be disabled via the dashboard, only enabled.

    mismatching upper case and lower case folder name extractions leads to the ability of being to enable the plugin if the names match (irregardless of case) but the inability to disable the plugin if the upper and lower case differ. This ia a flaw in vanilla. it should either allow you to disable a plugin if there is an upper or lower case mismatch or it should not allow you to enable it if there is a case mismatch,

    I filed this issue on github a while ago. https://github.com/vanilla/vanilla/issues/1750

    Until then plugin developers MUST make folder name xxxXXXxxx match the name in $PluginInfo['xxxXXXxxx'], otherwise the plugin can be enabled, but not disable via the dashboard.

    the only remedy is to disable the plugin via the config.php

    e.g.

    delete this line to disable it until it is fixed.

    $Configuration['EnabledPlugins']['wordcount'] = TRUE;

    filed this issue here:

    https://github.com/kasperisager/vanilla-wordcount/issues/3

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    unixhero
  • peregrineperegrine MVP
    edited June 2014

    aside from disable issue with wordcount-plugin-2.1.0

    same problem with these plugins can't disable oembed 2.01, mediumeditor 1.01, wysihtml 2.01, and timeago 2.01

    because unzipped foldername being lowercase and $PluginInfo name being mixed case.

    https://github.com/kasperisager/vanilla-wordcount/issues/3

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    unixhero
  • Thanks peregrine! You've been super helpful! :) This solved all my issues ;)

    peregrine
  • @carsenk said:
    Thanks peregrine! You've been super helpful! :) This solved all my issues ;)

    awesome. thx for the feedback.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    unixhero
Sign In or Register to comment.