HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Please upgrade here. These earlier versions are no longer being updated and have security issues.

[Solved] Fatal error: Class 'Gdn' not found*

tvetbergtvetberg New
edited June 2014 in Vanilla 2.0 - 2.8

Hi, I'm trying to install Vanilla forums 2.1 latest stable build on MAMP. Have downloaded and extracted the vanilla folder directly in the htdoc but when I try to access the localhost the page is just blank. Went in to the /conf to edit config.php and enable debug but there is no config.php there, only the config-default.php.

Maybe a noob error? Does not have much experience with local hosting nor databases but want to help my friend to find a good forum solution for a website. This is the best forum solution around, right? :)

UnderDog
«1

Comments

  • are you connected to the internet when you make attempts to install.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Yes I am via iPhone 4G

  • I mean is the localhost that you are trying to install it on connected to the internet.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Sorry but I do not understand. The MAMP is running on the same Mac that I'm using and its connected to internet. Is this what you asking?

    UnderDog
  • peregrineperegrine MVP
    edited June 2014

    yes.

    do you see tables created in the database you created?

    did you follow the instructions on the permissions of the conf folder.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Hmm, no.

    But for Vanilla to create something in my DB I must first get to the installer and set DB name, user and password am I wrong? But it is the installer I can't access.

  • Im not sure what instructions you are referring to. This is what I have done:

    Downloaded, installed and run MAMP

    Downloaded vanilla and extracted the files to MAMP´s htdocs

    Trying to access the install page from localhost and nothing happens.

    I also created a DB via phpmyadmin and created a new user with full permission. But if I can't access the install page I can't fill in my DB information?

  • peregrineperegrine MVP
    edited June 2014

    so you can't even get to the install screen at all.

    can you show a screenshot of your file folder structure.

    is your folder structure (where htdoc is your "root " folder.)

    htdoc/Vanilla

    make sure all the files are readable by the web process owner and that the conf folder is writeable by the web access owner.

    someone else may have to help - I don't use mamp.

    you might create a page in the folder where vanilla is installed called

    phpinfo.php

    and put this info in it

    <?php
    phpinfo();
    
    ?>
    

    and then see if you can access the page. via url in your browser. if not your web server is not working correctly or the folder permissions are wrong or your .htaccess is messed up.

    Confirm all folders and files are readable by PHP

    Confirm the cache, conf, and uploads folders are writable by PHP.

    i don't know if this works on an mamp

    whoami.php

    <?php system("id");?>

    or possibly

    <?php pass_thru ("whoami"); ?>

    then post your results.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Yes, thats the problem. I can't access the the install page at all its just blank. Tried to access http://localhost:8888/index.php but still just blank.

    Heres my structure. I have but all the vanilla files in the /htdocs

    As you can see I tried making a phpinfo.php and yes i can access it from http://localhost:8888/phpinfo.php

    How do I make sure the files are readable? I haven't had to change that kind of stuff when installing wordpress and prestashop on my MAMP.

  • peregrineperegrine MVP
    edited June 2014

    why are you using port 8888 that MAY be your issue.

    As you can see I tried making a phpinfo.php and yes i can access it from http://localhost:8888/phpinfo.php

    I believe you, but obviously I can't see it. because i can't access your local host.

    you might want to grab a screen shot of it and post it.

    I have but all the vanilla files in the /htdocs

    so does that mean you have it like this

    /htdocs/applications

    How do I make sure the files are readable?

    google how to find file owner! google file permissions.

    you need a person familiar with MAMP, and thats not me. sorry.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    UnderDog
  • peregrineperegrine MVP
    edited June 2014

    although this should NEVER be done under ordinary circumstances, meaning never change config-defaults.php - try changing the line TEMPORARILY in config-defaults.php

    from

    $Configuration['Debug'] = FALSE;

    to

    $Configuration['Debug'] = TRUE;

    just for an experiment - since you haven't been able to get anywhere. and then change it back to FALSE if you get an install screen and a config.php is created.

    normally you don't ever change config-defaults.php

    but since you don;t have a config.php yet try it.

    if you get an error post it.


    the other option since you get a blank screen when trying to install is to temporarily change index,php

    from

    ini_set('display_errors', 0);

    to

    ini_set('display_errors', '1');

    to see if you get some error message instead of a blank screen.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    UnderDog
  • tvetbergtvetberg New
    edited June 2014

    Ive changed it to port 80 for apache and 3306 for MySQL.

    The phpinfo.php is pretty long, is there some part of it you want to se?

    Yes its like /htdocs/applications


    I know after reading the readme.txt that i should not change the config-default.php but I've tried to do so with no effect, still blank. For some reason i do not have a config.php

    After changing the ini_set to 1 i get this error

    Fatal error: Class 'Gdn' not found in /Applications/MAMP/htdocs/bootstrap.php on line 41

  • peregrineperegrine MVP
    edited June 2014

    does it show you any id info in your phpinfo()

    load phpinfo and search for User (depends in your phpinfo whether it is displayed).

    e.g.

    User/Group www-data(33)/33

    do you have a constants.php in your conf folder.

    once again you may need to find out who owns the folders and their permissions, or you might be going to a path leading to nowhere until you understand permissions and ownership, and find out out to see it with the program you use to view file structure.

    what I would do is this, if it were me.

    just download the zip again leave it in the folder Vanilla

    so it is

    htdocs/Vanilla/

    and see if you can get it working that way.

    make sure the conf cache and uploads folders are writeable by your php owner as suggested in:

    http://vanillaforums.org/discussion/comment/210973/#Comment_210973

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    UnderDog
  • What an interesting situation. Let's see what to do to show more info than the blank page ... first in index.php add / change this line: ~~~ini_set('display_errors', 0);

    to

    ini_set('display_errors', '1');~~~
    After that consider changing the error_reporting options, maybe even to E_ALL. Forgot where to change that option though, hope it's in index.php

  • I already changed from 0 to 1 and get the following message when trying to access index.php via localhost.

    @tvetberg said:
    Fatal error: Class 'Gdn' not found in /Applications/MAMP/htdocs/bootstrap.php on line 41

  • @peregrine said:
    does it show you any id info in your phpinfo()

    load phpinfo and search for User (depends in your phpinfo whether it is displayed).

    e.g.

    User/Group www-data(33)/33

    Mine says:
    User/Group Tvetberg(501)/-1

    do you have a constants.php in your conf folder.

    Yes

    once again you may need to find out who owns the folders and their permissions, or you might be going to a path leading to nowhere until you understand permissions and ownership, and find out out to see it with the program you use to view file structure.

    Im the only user of this computer (a Mac latest OSX) so I must have the permissions? I know the issues of permissions on Windows but not on Mac?

    what I would do is this, if it were me.

    just download the zip again leave it in the folder Vanilla

    so it is

    htdocs/Vanilla/

    Ive tried that but with the same result.

  • peregrineperegrine MVP
    edited June 2014

    if you ever decide to install on Ubuntu and you have a problem, let me know :)

    i ran from apple and windows in the early 90's and didn't look back.

    other than installing on a different OS and then moving it to MAMP and uploading database, I can;t help.
    I'm MAMP illiterate.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    tvetbergUnderDog
  • @peregrine said:
    if you ever decide to install on Ubuntu and you have a problem, let me know :)

    i ran from apple and windows in the early 90's and didn't look back.

    Thanks for trying to help!

    peregrinehgtonight
  • tvetbergtvetberg New
    edited June 2014

    Summary:

    On clean intall of the latest stable build of Vanilla Forum 2.1 on MAMP 3.0.4 I can't access the installation page. When going localhost or localhost/index.php the page is blank white aka nothing appears.

    After changing ni_set('display_errors', 0); to ni_set('display_errors', 1); I get the following message:

    Fatal error: Class 'Gdn' not found in /Applications/MAMP/htdocs/bootstrap.php on line 41

    EDIT:

    Read this on another thread on the Class 'Gdn' not found error.

    "Try deleting any .ini files in your cache. That has helped on the "Gdn not found [...]" a couple of times."

    That did wok, I nog get trough to the installation page but there is a new error there:

    "You are missing Vanilla's .htaccess file. Sometimes this file isn't copied if you are using ftp to upload your files because this file is hidden. Make sure you've copied the .htaccess file before continuing."

    UnderDogperegrinehgtonight
  • tvetbergtvetberg New
    edited June 2014

    SOLUTION

    Problem 1: Page returns blank when accessing index.php.

    Solution: "Try deleting any .ini files in your cache. That has helped on the "Gdn not found [...]" a couple of times."


    Problem 2: When finally installation starts you get the message: "You are missing Vanilla's .htaccess file. Sometimes this file isn't copied if you are using ftp to upload your files because this file is hidden. Make sure you've copied the .htaccess file before continuing."

    Solution: Check Vanilla folder for hidden .access file and make sure it is copied to root destination. In my MAMP that would be htdocs.

    peregrinehgtonight
Sign In or Register to comment.