HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Upgrade from 2.0.18.11 to 2.1 failed bad

I followed the simple directions carefully. (glad I took a snapshot before starting)

Deleted the ini files.

Followed peregrines advice and switched to the default plain template before starting.
Also de-activated ALL plugins. Took forever... I have 35 active.
Turned the url rewriting off too.

Uploaded the new files.... ran the utility/upgrade script... and BOOM, got that useless message that the upgrade failed with NO debugging info. Tried this 3 times. Also recursively set all file permissions to 755 after I uploaded all the new files.

I can debug on my own... but come on... give me SOMETHING to work with. That message is so damn useless :(

Where do I go from here? I need things to try. Is there a debugging flag I can set or something so I can get an exception?

UnderDog
«1

Comments

  • peregrineperegrine MVP
    edited July 2014

    what message are you referring to?

    see the troubleshooting tips here:

    http://vanillaforums.org/discussion/26685/vanilla-2-1-stable-released/p1

    this may help also:

    there are quite q few tips as well in the entire discussion thread.

    http://vanillaforums.org/discussion/comment/208629/#Comment_208629

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    UnderDog
  • Same one as the other guy you were helping:

    http://www.screencast.com/t/dZE5PS79RY

  • what other guy?

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • try running /utility/update a few times.

    you might know the discussions you are referring to, I don't however without you specifying a link.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    UnderDog
  • peregrineperegrine MVP
    edited July 2014

    the best way to upgrade is to read the messages or announcements relating to the version you are using if they are posted. (at this point they are). They will give you tips and ideas, as well as the readme in the core zip file itself. Other discussions may help as well, but it is a good idea to read at least the developers notes.

    as indicated by the two message announcements at the top of this forum.

    http://vanillaforums.org/discussion/26685/vanilla-2-1-stable-released/p1

    http://vanillaforums.org/discussion/26686/new-official-docs-repo-changes-site-updates-and-releases

    https://github.com/vanilla/vanilla/blob/master/README.md

    follow the instructions and troubleshooting in those announcements.

    this and the comments preceding it may also help.
    http://vanillaforums.org/discussion/comment/210962/#Comment_210962

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    UnderDog
  • Dang it...... can we get THIS page deleted?
    http://vanillaforums.org/docs/installation-upgrade

    These instructions are clearly lacking compared to THIS page:
    http://vanillaforums.org/discussion/26685/vanilla-2-1-stable-released/p1

    hgtonight
  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    You need to set the theme to the default theme and delete the default.master.php from applications/dashboard/views/default.master.php

    use RewriteURL true and check the htaccess file it may have been overwritten.

    Delete the ini files inside the cache and also the ones inside the compile folder that is inside of Smarty

    run utility/structure while in the dashboard

    UnderDog
  • Followed everyones advice.... but so hard to tell if things worked or not.

    When I go to /dashboard/utility/structure
    I see this: http://i.imgur.com/fXVewQJ.png

    If I hit the button "RUN STRUCTURE AND DATA SCRIPTS" at the bottom of that page... I think it did something the first time... but hard to tell.

    Now when I run it, I get this:
    http://i.imgur.com/DiZvHH6.png

    Does this mean its already been updated correctly?

  • Well, looks like this attempt was a failure.
    Clicked on the Activity link, and BOOM, got this:

    http://i.imgur.com/YipIaJr.png

    Followed all the instructions... zero plugins involved and this upgrade doesnt work. This is not confidence inspiring. :(

  • Also.... a web page based update is just a bad idea.
    I have a 300 meg database. There is no way the upgrade can run within the confines of a gateway timeout.

    It timed out... then I ran TOP in unix and waited until MYSQL dropped from 100% usage, indicating the upgrade finally finished before I continued. But thats a guess. I dont like guessing.

    If a web page based update is going to be used, it should really use a refresh mechanism that shows % complete as the script runs. No script should run for more than 5 mins either. Most systems wont allow that anyway.

    Upgrade should be done in pieces using a refresh script. Otherwise, this is likely only going to work on SMALL SITES.

    Or at least provide a command shell upgrade script for big sites.

  • well is is part of structure.php so it should have been created

    if (!$NotifyUserIDExists && $ActivityExists) {
       // Update all of the activities that are notifications.
       $SQL->Update('Activity a')
          ->Join('ActivityType at', 'a.ActivityTypeID = at.ActivityTypeID')
          ->Set('a.NotifyUserID', 'a.RegardingUserID', FALSE)
          ->Where('at.Notify', 1)
          ->Put();
    
       // Update all public activities.
       $SQL->Update('Activity a')
          ->Join('ActivityType at', 'a.ActivityTypeID = at.ActivityTypeID')
          ->Set('a.NotifyUserID', ActivityModel::NOTIFY_PUBLIC)
          ->Where('at.Public', 1)
          ->Where('a.NotifyUserID', 0)
          ->Put();
    
       $SQL->Delete('Activity', array('NotifyUserID' => 0));
    }
    

    run

    /utility/structure

    then

    /utility/update

    grep is your friend.

  • After running /utility/structure
    how do you KNOW it worked???

    I get this http://i.imgur.com/DiZvHH6.png
    which seems to indicate its already been run?

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    It is a good idea to run utility/structure several times until it says all is ok specially if the DB is large

  • I dont see how that will work.

    /utility/structure shows the SQL its going to execute.
    And one of the first things it does is, add some new indexes.
    The NEXT time you run it, it doesnt seem to detect the index is already there, so it blindly tried to run it again which throws a SQL exception that the index already exists. So then it stops executing and goes no further.

    I have copied all the SQL that /utility/structure shows into a file and ran it directly against MYSQL from the command line.

    This way, when it complained about a conflict its already fixed, I just deleted that SQL so it would go FURTHER the next time I pushed the remaining SQL code through.

    Ive got it all executed now except for one final SQL command.

    Im having a hard time believing this upgrade would work for anyone the first shot though.

    Hope to have it working soon...

    vrijvlinderUnderDog
  • Really... weird, here is the last bit of SQL that needs to execute:

    alter table GDN_UserRole
    add primary key (UserID, RoleID);

    But it throws the error:
    ERROR 1062 (23000): Duplicate entry '5-8' for key 'PRIMARY'

    However, show create table, shows the table currently has no PRIMARY key....
    Hmmmmm.....

    mysql> show create table GDN_UserRole;
    +--------------+-----------------------------------------------------------------------------------------------------------------------------------------------------+
    | Table | Create Table |
    +--------------+-----------------------------------------------------------------------------------------------------------------------------------------------------+
    | GDN_UserRole | CREATE TABLE GDN_UserRole (
    UserID int(11) NOT NULL,
    RoleID int(11) NOT NULL
    ) ENGINE=InnoDB DEFAULT CHARSET=utf8 COLLATE=utf8_unicode_ci |
    +--------------+-----------------------------------------------------------------------------------------------------------------------------------------------------+

    Im using MySQL 5.1.x

  • Also this....

    mysql> show index from GDN_UserRole;
    Empty set (0.00 sec)

  • It is trying to create one but there is a duplicate entry, for some reason. You might see what roles you have.

    grep is your friend.

    jackjitsuUnderDog
  • Crap..... now I see whats going on. I have a custom role that is causing a conflict with the new two key primary key... grrrrr

    UnderDog
  • x00 - you nailed it... beat me to the post.

Sign In or Register to comment.