Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product

Ready to contribute?

Amazing! Sign our contributors' agreement and then join us on GitHub.

Update for critical security issue in PHPMailer included in release Vanilla 2.3.1
Please upgrade to 2.3 here. The 2.2 and earlier branches are no longer being updated.

DarkMetalMobile unable to type

This discussion is related to the DarkMetalMobile addon.

I love the mobile theme. However, I am unable to reply to posts or initiate a new discussion because the phone keyboard does not come up when I tap on the comments block. I've tried everything with no success. Currently the mobile version of the Forum is "Read Only" because there's no way to type. I am using the 2.1 version.

Comments

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    Thanks for trying my themes, what editor are you using ? I tested this with Safari , Firefox , Chrome and Opera. But not in IE since I do not use it.

    If you make a test account and pm me the info I will check it out asap

    UnderDoghgtonightperegrine
  • Excellent. I appreciate your assistance. Here's the link: http://bulliesofnc.com/BTforum/ Login: JustTesting Password: testing!

  • I am using a Samsung S4 phone. I've tried it using their default browser along with google chrome. I also tried it with my wife's phone (Altel) and could not utilize the keyboard either.

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    This will be hard for me to test because I use iPhone and it works for me. The only thing I notice is some width adjustment for the form I will upload a better version asap for the mobile theme with these details fixed.
    I will look into it further. Have you tried this with the default mobile theme? Does the keyboard show up when you tap the form ?

  • It used to work before on whatever theme I was using. I heard from someone else they too were able to access the keyboard from their iPhone.

    vrijvlinder
  • vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited July 2014

    I uploaded a new version please see if that improved. I will need to look into why tapping the form in a samsung won't trigger the keyboard. Are you using cleditor editor ? That could be the trouble for the mobile phone

    peregrineUnderDog
  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    ok a friend came to see me today and she had a samsung and I was able to see what is happening. The keyboard shows but hides again. This is due to cleditor editor. If you try it with another editor like the default or button bar the problem does not happen. If you press on the form instead of tapping it the keyboard stays but the form auto grows very long. cleditor is not very good for mobiles.

    UnderDoghgtonight
  • I'm not sure what "cleditor editor" is. If it's a Plugin I don't see it listed. None of the editors work with this Theme since the yellow bar hides all the editing tools. I tried the button bar plugin and it shows up but does not function. I'm still trying to figure out how to comment from my phone and prevent the keyboard from disappearing.

  • vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited July 2014

    I tested my themes with all editors for vanilla and they all work for me on iPhone .
    Did you try the new version I uploaded ?

    cleditor is a plugin and you do or did have it enabled, I know because the style I added to it only shows if you have it enabled..The reason why you don't see the editor buttons is because the buttons.gif has the wrong url.

    I am sorry you are having these problems I will try to get to the bottom of this.

    Please update the theme with the new one I uploaded or change to this in line 2185

    .cleditorButton {
    float: left;
    width: 24px;
    height: 24px;
    margin: 0px 0 1px 0;
    }
    

    If you could help by using a web inspector like firebug or chrome web inspector, you would be able to see exactly what is happening. Then you would be able to fix it easily.
    From What I can see you have a javascript problem on your forum. And you did not update the mobile theme with new version because I still see the same issues.

    Cleditor editor is enabled but is not functioning properly. Please disable it before you enable other editors.

    UnderDogperegrine
  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    The theme is a nice one and looks very good on their site, now we just need to fix details is all. :)

    UnderDogperegrine
  • @vrijvlinder - I truly appreciate you working with me on resolving these issues. I just installed your updated version and unfortunately still continue with the same issue of not being able to type. the keyboard appears for a split second and then disappears. I understand that correcting certain issues may be time consuming and tedious. Is there a way I could pay you for services to resolve this issue along with a couple others for my forum? I may not have the knowledge and capabilities to tackle it. I like the theme a lot because it's probably the cleanest one out there that's easy to read and has a nice modern look to it. There are a few issues with the normal dark theme as well as the mobile version. Correction to these issues would create the best theme available hands down.

    vrijvlinderperegrine
  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    It is no problem at all I support all my themes and you don't have to pay me, the fact you like it and are using it is payment enough.

    The issue with the keyboard on the samsung has to do with javascript and the cleditor editor. You are not the first to notice this issue which also happens with the default theme or other themes and cleditor editor.

    Have you tried disabling the cleditor plugin and just leave the default text form to see if the same happens?

    If you could make a list of the details you notice that need correcting then I can get on with it and fix them as they come up. This week is my last week here in Mexico and will be a bit busy during the day but at night I have more time. Then on thursday I fly back home and will be able to spend more time if needed. Normally I can fix something right away as soon as it is pointed out and to me, it is only easier because of practice but I am sure you will get the hang of it too.

    peregrineUnderDogBulliesofNC
  • edited July 2014

    You were correct. I looked for the cleditor editor within my plugins and found it. The plugin is titled "WYSIWYG (CLEditor). Once I disabled that plugin it solved the problem with the inability to type while on a mobile device. It also deleted that yellow bar at the top. Obviously it took away the option of any editing tools. However, I noticed that the "Button Bar" plugin worked fine. It may not have as many editing options like the WYSIWYG like Font Size, Font Type, highlighting, etc but it does give you some of the basic options. I may try a few other editor plugins to see if there's a better one than the "Button Bar."

    Thanks for solving this particular glitch. :)

    vrijvlinderUnderDog
  • edited July 2014

    I tried using the updated version of the Cleditor which is: CLEditor jQuery WYSIWYG version 0.5. This plugin actually worked perfectly with the normal dark theme and icons weren't hidden behind a yellow bar. However, the mobile theme once again lost the ability to type. Rats!

    Trying to test on this page: http://www.bulliesofnc.com/BTforum/discussion/1987/forum-editing-testing#latest

  • vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited July 2014

    The problem with the line breaks I fixed in the new version however I am not sure if you installed it because I still see this in line 702 in the custom.css when I inspect the code. This is in the DarkMetal not mobile.

    .Message br {
    display: none;
    }
    
    UnderDogperegrine
  • Oh ok. I only downloaded the updated mobile version. I will download the new DarkMetal theme now. Thank You.

    UnderDogvrijvlinder
  • Awesome! Once again you provided correction to a problem without dilemma. Thank You.
    Later, I will put together a list of other glitches. I think there are only a couple other ones. I will post them to the DarkMetal plugin page vice this Mobile Version. Since it pertains to the regular theme vice mobile theme.
    Thanks so much for all the expedited help. It really means a lot.

    peregrineUnderDoghgtonightvrijvlinder
  • edited July 24

    Hi, I really like your dark themes and have both Dark Metal and Dark Metal Mobile installed. But when I click on Menu Mobile View I get a message User Not Found. Also, there's no "Search" box. Not sure what I'm doing wrong. Thanks for any help. Sorry--posted in the wrong place.

Sign In or Register to comment.