Please upgrade here. These earlier versions are no longer being updated and have security issues.

Are all my themes are broken?

I am using WAMP to host a copy of vanilla on my localhost. So far everything went smoothly. I have just begun playing with different themes, but one problem persist. All the themes I try seem to be broken. They load, but all the content is out of alignment. The only themes that work for me are the default themes that come with vanilla. This problem has persisted on all 5 of the popular themes I downloaded & applied; Therefor it must be a problem on my end.

Window 7 home premium
Latest Version of WAMP
Latest Version of Vanilla
Screen-cap of the Issue (Content Misalignment): i.imgur.com/SIifNqM.png

I'm sure it is something simple but as php & vanilla beginner, I have racked my brain with this one.

Best Regards,
Russ

Best Answer

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... Moderator
    Accepted Answer

    @russpatt‌

    Welcome to the community.

    It looks like a missing (or extra) DIV tag in the theme's default.master file to me, from that screenshot.

    What version number of Vanilla are you using?

    Are you getting the themes from the addons section?

    If you are using 2.1, try downloading this theme:

    http://vanillaforums.org/addon/annotatedcss2.1-theme

    I made it to help new users work out how to apply basic styles to Vanilla.

    If that is shown as misaligned, there must be something wrong with your setup somewhere.

    russpattUnderDog

Answers

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    If anyone looks at that discussion when there is Vanilla version 7 the current version, this discussion will not be of any help. So please specify your version when you ask a question. But I assume you are using Vanilla 2.1 (don't use the latest version from github which is something like 2.2!)

    Danca has not been updated since mid of 2012 when Vanillas current version was 2.0.something. Therefore it is untested for you version and that's why it might not work on you server. Try one of the more recent created themes and see if they also don't work


    UnderDog
  • whu606whu606 I'm not a SuperHero; I just like wearing tights... Moderator
    Accepted Answer

    @russpatt‌

    Welcome to the community.

    It looks like a missing (or extra) DIV tag in the theme's default.master file to me, from that screenshot.

    What version number of Vanilla are you using?

    Are you getting the themes from the addons section?

    If you are using 2.1, try downloading this theme:

    http://vanillaforums.org/addon/annotatedcss2.1-theme

    I made it to help new users work out how to apply basic styles to Vanilla.

    If that is shown as misaligned, there must be something wrong with your setup somewhere.

    russpattUnderDog
  • Yeah I thought about that, I suppose I just got lazy and didn't look. I am using Vanilla-Core-2-1.
    I will find some newer themes to try, and report back soon.

Sign In or Register to comment.