Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Embed Flash with HTML extension?

edited July 2007 in Vanilla 1.0 Help
Is there anyway to do this? No flash seems to embed for me? Using code directly like this: <object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase=",0,0,0" width="457" height="288"> <param name="movie" value=""> <param name="quality" value="high"> <parm name="menu" value="false"> <embed src="" quality=high pluginspage="" type="application/x-shockwave-flash" width="457" height="288"> </embed> </object>


  • That's because it disables embed and object tags for security reasons. However, if you'd still rather be able to embed objects then you can simply remove the tags you don't want (and their corresponding seperator) from the line that looks like this:"/<[\/]*(link|iframe|frame|frameset|object|embed|style|applet|meta)[^<]*?>/i",
  • awesome, thankyou.
  • where is the line?
  • line 29 in extensions/HtmFormatter/default.php
  • thankz
  • edited July 2006
    This helped alot for me too, thanks ^_^d
  • I tried that but it didn't work for me. My problem is that I get a 403 error when I try to add the iframe tages in a Page or in a Discussion. Is this a problem with my server? If so, what can I do to remedy this? Thanks
  • a_ja_j
    edited July 2006
    @jimw does the whole page 404, or just in the iframe? if it's in the iframe it's just a matter of setting the correct path to the page (try using an absolute path e.g. <iframe src=""). also make sure that you are allowing iframes by removing them from the above mentioned line of code. edit: oh, it's a 403 error. this probably means that there isn't an index page in the folder. try setting the absolute path, or create an index page. so if you were setting the src to, try setting it to the exact page you want to display like
  • I'm trying to call filebrowser in an iframe. It has an index.php but no index.html. I tried the complete name to the index.php file, but still got the error. Should I make an empty index.html file in the folder? As an alternative, or temporary solution, I set my Page tab to execute filebrowser. That works.
  • So right now it's opening the filebrowser in a new page I take it? You can try to create a little index.html file, or point the iframe to an index.html that is already on your server somehwere and see if that works.
  • Would it be possible to embed Flash content using swfOjbect? (
  • edited July 2006
    I just added an empty index.html, but that didn't solve the problem. Since I am having the same problem in WordPress, I'm thinking it is a server problem. It works fine on my local installs.
  • a_ja_j
    edited July 2006
    I suppose you could, but it's not exactly user-friendly for people inexperienced with code that just want to throw up a youtube video

    this is the minimum code required to use swfobject (via their site)
    <script type="text/javascript" src="swfobject.js"></script> <div id="flashcontent"> This text is replaced by the Flash movie. </div> <script type="text/javascript"> var so = new SWFObject("movie.swf", "mymovie", "200", "100", "7", "#336699"); so.write("flashcontent"); </script>

    this will probably confuse most people. "Whats 200 mean?", "What's #336699?".

    If you wanted to use it i suppose you could just upload the folder to the js folder in vanilla, and via htmformatter extension default.php create a new line

    then use the code above to embed movies.
  • You are right, I didn't think of that... not sure what if any of these values you can extract automatically, probably none...
  • Thank you for the extension and for allowing the use of SWF.
This discussion has been closed.