Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Can't view messages after 2.1.1. upgrade

Hi, I'm having a few issues after the 2.1.1 upgrade. The first one is with viewing/sending messages.

When I send a message I get the error:
Fatal Error in AddPeopleModule.FetchView();
Could not find a addpeople view for the AddPeopleModule module in the conversations application.
(do you need the whole error?)

But the message is actually sent to the right person. I get the same error when I try to view any message. I can see them all in my inbox but when I click on one I get the error.

This doesn't happen on my phone (Android, using firefox mobile browser). It does happen on my windows8 laptop using firefox 31. One other user reported the problem - I think she's on Mac.

I've disabled all plugins except "private Community".

Users are also reporting problems (e.g., emails now going to spam, links are gray and don't work, notifications not appearing). I'm trying to get more info on those.

I'd appreciate any assistance! Btw, I'm not a developer, just someone with enough knowledge to be dangerous.

Comments

  • peregrineperegrine MVP
    edited August 2014

    perhaps. because you didn't copy over all the files properly

    I would reinstall (re-copy zip files), if you don't see this file

    applications/conversations/views/modules/addpeople.php

    and make sure everything has read permissions for php process.

    if may clear up the rest of your issues as well.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    UnderDog
  • peregrineperegrine MVP
    edited August 2014

    hdjohnston said: I'm not a developer,

    it reminds me of a star trek phrase, although I only watched a few episodes.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    vrijvlinder
  • It is missing. Guess that's why it can't find it. D'oh! And now I get what that error is referring to so the learning continues.

    Thanks Peregrine! Helpful as always!

  • @peregrine said:
    it reminds me of a star trek phrase, although I only watched a few episodes.

    Dammit, Jim, I'm a magician not a developer!

    peregrineUnderDogvrijvlinder
  • Oh, when you say make sure everything has read permissions, do you mean everything (!) or everything the errors are referring to?

    UnderDog
  • peregrineperegrine MVP
    edited August 2014

    all your vanilla files have to be readable by the web process.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    UnderDog
  • peregrineperegrine MVP
    edited August 2014

    @hdjohnston said:
    Dammit, Jim, I'm a magician not a developer!

    you have a sense of humor, even in times of vanilla trouble, that's a good thing.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    vrijvlinder
  • Woohoo! Thanks @peregrine‌! I couldn't try again until tonight but I got a new ftp client and it all seemed to go well.

    Once again, you the peregrine!

    peregrineUnderDog
Sign In or Register to comment.