Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Upgrade to Ver. 1 Failed then fallback to previous Ver. Failed

edited July 2006 in Vanilla 1.0 Help
I backed up my files and database. I then replaced the new appg/settings.php, database.php, and language.php files with my original ones. After, I deleted my original folder of forum files and uploaded a complete set of new files with the three php files mentioned above. The following happened when trying to run the upgrader:

1. The upgrader asked me to rename settings.php to old_settings.php and upload it into the conf folder.
2. I did the following and attempted to proceed to the next step.
3. The upgrader asked that I change the permissions on the conf folder.
4. I went to check the conf folder and old_settings.php permissions and was already set up and ready to be "read" and "written" on.
5. I tried to proceed to step 2, and it continued to give me the error that my conf folder should have read and write permissions, which it already does

So I decided to fallback to my previous version because I already had all the files and databases backed up. I deleted the version 1 files and uploaded my old forum files in the same exact location. I then tried to access my forum and the following error came about:

Parse error: parse error, unexpected T_STRING in /home/thesama/public_html/bbs/library/Vanilla.Discussion.class.php on line 650

Any help would be appreciated to explain why my version 1 upgrade failed or why my previous version of Vanilla won't function properly at the moment. Thanks.

Comments

  • Options
    TreyTrey Charlotte NC New
    the conf folder itself needs to have read and write permissions (chmod 777)

    hopefully that helps, but I'm not sure =/
  • Options
    "4. I went to check the conf folder and old_settings.php permissions and was already set up and ready to be "read" and "written" on."

    I even went back to reapply the read and write permissions, but that was no help. Thanks for the reply.
  • Options
    MarkMark Vanilla Staff
    try re-uploading your files, It sounds like an ftp garbling error.
  • Options
    I tried re-uploading each file one by one and I get the same error. Was I supposed to reload the database as well?
  • Options
    lechlech Chicagoland
    mark, what are the chances of Vanilla updating the DB to 1.0 and barfing before? slim right, but the DB here could be updated. I think the only move here is to keep the DB and reapply a fresh version of the base files for it to refference. Then it's just a matter of pulling the settings back together from scratch.
  • Options
    MarkMark Vanilla Staff
    "unexpected T_STRING" means that there was a basic php parsing error. Normally if you see this it means that the file has been messed up. Take a look at that file in particular (library/Vanilla.Discussion.class.php) to see if it's been messed up (open it up and look at that line: 650).
  • Options
    edited July 2006
    Thanks for the help guys. I just checked the Vanilla.Discussion.class.php file like Mark suggested. I'm not very php savvy so maybe someone could help me out:

    image
  • Options
    I decided to go with lech's advice and upload a complete new set of files and trust that the old database would still be there. I'm finally upgraded to version 1. *man tear* Thanks for the help guys.
  • Options
    MarkMark Vanilla Staff
    Yay!
This discussion has been closed.