Please upgrade here. These earlier versions are no longer being updated and have security issues.

[FIXED] Profile Extender broke down :(

AccentAccent
edited September 2014 in Vanilla 2.0 - 2.8

Hey all,

I've run into a weird issue with the Profile Extender plugin (I didn't find a page dedicated to it so I'm posting this in the general vanilla help section... probably because it's a core plugin?)

What happened is, I wanted to change where the custom fields were displayed in a user's profile, so in class.profileextender.plugin.php I changed public function UserInfoModule_OnBasicInfo_Handler($Sender) to public function UserInfoModule_AfterUserInfo_Handler($Sender).

This didn't work, so I changed it back, but now all kinds of issues have appeared!

1) Trying to edit your profile triggers a bonk error. Here is the debug info:

Illegal string offset 'FormType'
The error occurred on or near: /home/robinvne/public_html/recreatio/plugins/ProfileExtender/views/profilefields.php

  2: 
  3: if (is_array($this->ProfileFields)) {
  4:    foreach ($this->ProfileFields as $Name => $Field) {
  5:       $Options = array();
  6:       if ($Field['FormType'] == 'Dropdown')
  7:          $Options = array_combine($Field['Options'], $Field['Options']);
  8: 
  9:       if ($Field['FormType'] == 'CheckBox') {
 10:          continue;

(Line 6 is highlighted.)

2) In the admin dashboard, when going to the plugin's settings, four text fields are displayed: Profile Fields, Registration Fields, Hide Fields and Text Max Length. Previously I had a table where I could add, edit and remove any custom field I wanted, and pick whether I wanted each one to be a TextBox, a Dropdown menu, a Checkbox menu, etc.
Now this has disappeared.

I tried disabling and re-enabling the plugin, reverting back all of the files to their initial state, removing any mention of the plugin in config.php, removing the existing custom fields from my database... nothing worked. Whenever I re-enable the plugin, the four fields reappear and are automatically filled with "Location,Facebook,Twitter,Website", "Location" and "140", and the profile edit page breaks.

What should I do?
Cheers.

Comments

  • Well, nevermind that... I re-downloaded a vanilla core installation and took the ProfileExtender folder from it and uploaded it to my forums after disabling the plugin. Now that I've re-enabled it, it looks like everything's working... The plugin has probably had an overhaul with the latest version of Vanilla and I uploaded an old file.

    hgtonight
Sign In or Register to comment.