Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

CommentRemoval addons

edited February 2007 in Vanilla 1.0 Help
Hi; i take error when i use comment removal extention. Affected Elements RemoveComment.RemoveComment(); The error occurred on or near: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'select WhisperUserID from lum_comment where CommentID = 587) !=


  • Which version of mysql?
  • my mysql version is 4.0
  • NickENickE New
    edited July 2006
    Do you have the latest version of the extension? I went ahead and took out that sub-query, it was sort of redundant considering that column'd be non-zero anyway if it was whispered to someone.
  • CloughClough
    edited July 2006
    i updated it, i am using Comment Removal 1.4v addon. and i have get another error.
  • Where's your appg/ folder located? Is it at public_html/appg/ ? Because if it's not then you'll have to tweak the include() strings to point to the correct locations of your settings.php and init_ajax.php files.
  • yeap , includes it
  • So, does it work now? Are you still getting an error?
  • edited July 2006
    The error says it cannot find these files...

    include('..\..\appg\settings.php'); include('..\..\appg\init_ajax.php');

    I have them in the default location, this is part of the error...

    Error: Warning: main(..\appg\settings.php): failed to open stream: No such file or directory in /home/httpd/vhosts/ on line 6
  • i still get error, i think "/"s are wrong :S
  • Yes they looked wrong to me too.

    I replaced "\" with "/" but still no go. :(
  • edited July 2006
    i get the same mistake. after the replacing of the backslashes, too. the alert box shows: "Error:" and nothing more. the <><><> is still on display. the deletion has not occured.
  • so, after messing around, the mistake (so, kind of) is in the queries. the subselect inside the where clause does not work under (my) mysql 4.0.26. maybe s/b can check their version of the mysql.
  • Hmm, it appears the MySQL only supports sub-selects starting at version 4.1... Better revise my queries then. That's odd that the files are not including, though. I notice, Wanderer, that your error says "main(..\appg\settings.php)" It almost looks like part of the original file name was lost or something. And you're sure it include anything with forward slashes?
  • edited July 2006
    Forward slashes did not work SirNot, I restored a fresh version.

    Actually, with the forward slashes I got this error...

    Failed: (undefined) undefined
  • edited July 2006
    i click delete and nothing happens. :-( no error message, nothing.
  • NickENickE New
    edited July 2006
    Ugh... Did you get a js error timberford? It should at least pop up with a confirmation message box if js is enabled. Wanderer, is your MySQL version less than 4.1? Because this extension only seems to work with versions >= 4.1 at the moment. If not, then where did you get that error (was it a js error, php one, ...?)
  • SirNot, I am running MySQL 3.23.58

    It was a JavaScript error, right after "Are you quite sure you want to delete this discussion?"
  • Well that's at least one of your problems. I'm afraid this extension only works with MySQL versions greater than or equal to 4.1 at the current, so regretably you can't use it just yet.
  • Thanks SirNot,
    I have contacted my host asking if they have plans to upgrade MySql.
  • i have a problem with the plug in... the plugin worked in the past...

    but now, theres only a popup with: ERROR:
This discussion has been closed.