HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Im Using Logger but i get an error

I tried installation. It returns an error, however there is no text in the fatal error. Im using Vanilla 2.1.1 , im assuming Logger is not compatible and therefore wont work.

Comments

  • @gazzafm said:
    im assuming Logger is not compatible and therefore wont work.

    I'm assuming that someday you will debug the (probably) blank page and post the PHP error

    There was an error rendering this rich post.

    peregrinebusinessdad
  • peregrineperegrine MVP
    edited September 2014

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • businessdadbusinessdad Stealth contributor MVP

    @UnderDog said:
    I'm assuming that someday you will debug the (probably) blank page and post the PHP error

    I was about to write the same. :)

    @peregrine said:
    just tested Logger works in 2.1.2 and it works fine.

    Yes, I can confirm this. The Logger plugin is "version-neutral", it doesn't depend on any particular feature of 2.0/2.1.

  • I appreciate the feedback, however there seems to be an assumption that some of us are technically minded and know or understand how to debug and show the php error. Some of us can only post what we see on screen, which was a red box without any error message, however i will attempt to learn how to debug and post any further information, as ive read the readme.md and i undertsand i need to install logger followed by the other dependancies. Hard to do that if the logger plugin wont install

  • businessdadbusinessdad Stealth contributor MVP

    @gazzafm said:
    I appreciate the feedback, however there seems to be an assumption that some of us are technically minded and know or understand how to debug and show the php error.

    This is indeed the assumption behind the Open Source version of Vanilla Forums. It doesn't come with many fancy bells and whistles, because it's very much "developer oriented".

    Some of us can only post what we see on screen, which was a red box without any error message,

    however i will attempt to learn how to debug and post any further information

    That's the key. A blank error box is not a known error, it may be due to many causes. First thing that comes to my mind: unmet requirements, the most common of which is, usually, PHP 5.3 or later.

  • the error message simply says The addon could not be enabled because it generated a fatal error:

    <

    pre>%s

  • Checked PHP version on my host, its 5.3

    hgtonight
  • businessdadbusinessdad Stealth contributor MVP
    edited September 2014

    @gazzafm said:
    the error message simply says The addon could not be enabled because it generated a fatal error: < pre>%s

    In such case, the PHP error log is the next step. Once we find out what the error is, it will be easy to fix it.

  • peregrineperegrine MVP
    edited September 2014

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

Sign In or Register to comment.