Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product
Please upgrade to 2.3 here. The 2.2 and earlier branches are no longer being updated.

Issues with split/merge and bootstrap theme

This discussion is related to the Bootstrap addon.

Currently split/merge works fine with our forum when we have the embed friendly theme enabled. However, when we switch to bootstrap it seems like the counter in the bottom left corner is off. We will check 3 comments and it will say we only have 2 selected. It also happens that as we deselect comments the number of comments selected in the bottom left corner keeps counting up. Any suggestions on how to fix this?

Comments

  • peregrineperegrine MVP
    edited September 2014

    I can't replicate your issue in bootstrap or any other theme.

    what version of vanilla, what version of bootstrap, what version of split/merge?

    and is your forum actually embedded.

    I would upgrade vanilla, and see if the problem occurs if you are not embedded, if you are.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • swevestahswevestah New
    edited September 2014

    @peregrine‌ It's at least promising to know that they can work together! I was starting to think it might just not be possible.

    I just updated Vanilla to 2.1.3 before posting this to see if that would fix it but the problem is still there. It looks the version of the bootstrap theme I'm using is 2.3.1.

    Our forum is embedded but the problem happens on the non embedded version just the same.

    peregrine
  • so you say bootstrap has the problem. it shows x-1 comments selected.

    select comments in a discussions with split merge in bootstrap. and post a screenshot withthe message appearing.

    don't do anything else except change theme to defaulttheme, and then post screenshot of same discussion.

    Based on what you are saying the comments number will be different (but I don't think it will be).

    what split/merge plugin are you using i.e. version number?

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • I'm on version 2.1 of the split/merge plugin.

    Here is what I see currently when I check certain comments

    Here it is working on the embed friendly theme which we were originally using before switching to bootstrap.

    And here it is with the default theme - also working.

    It really does seem like the problem is with the bootstrap theme. It is a mix of the links in the box looking different and displaying x-1 comments.

  • peregrineperegrine MVP
    edited September 2014

    so not only is the comments checked message different. the last checkbox miraculously get unchecked for the comment by chipaudette. so the message really reflects the number of boxes checked, but the last checked comment seems to get unchecked, correct?

    why is that?

    Is everything embedded with your screenshots or everything unembedded.

    were you viewing both

    how many comments are in that discussion, is it the at last comment checkbox that always gets unchecked.

    also is that the last comments in the dicussions or the last comment on the screen.


    based on your screenshot the last comment checked doesn't get added to the total. and is not reflected as checked on a refresh.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • peregrineperegrine MVP
    edited September 2014

    do you see Checked in the class for the item - when you click on check in bootstrap.

    for all itemes you check. do you see any js errors.

    use firebug or web-developer tools.

    < class="Item Alt Mine ItemComment Checked">
    

    look at your POST statements in firebug - response headers, etc.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • So here's like a step by step of what's going on on a shorter one where you can see everything. This is on the unembedded version.

    1. Before clicking anything (2 total comments on the thread)

    2. Check one comment. No notification box that it's checked.

    3. Check second comment. Notification box thinks only one is checked.

    4. Uncheck first comment. Notification box thinks 2 are checked.

    Not sure about the errors, will check that now.

  • And I'm not getting any errors in the console

  • peregrineperegrine MVP
    edited September 2014

    what version number of split/merge plugin do you have.

    I also have different class designations.

    same questions, just repeated again :) plus some more.

    do you have the same problem with bootstrap when you disable all plugins via dashboard. and using different browser type , (all unembedded).

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • 2.1 version of split / merge

    and we have this problem on all browsers. I also tried installing a fresh split/merge plug in and that did not work either.

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... Moderator

    Out of curiosity, what about enabling the Split/Merge FE plugin, and seeing if the same issue arises?

    Personally, I prefer the FE version, as it has a bit more functionality.

    http://vanillaforums.org/addon/splitmergefe-plugin

  • @whu606 I tried both the default split merge and split merge FE and the problem is the exact same with both

  • the bootstrap theme needs to be updated to most recent version and tested again.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • peregrineperegrine MVP
    edited September 2014

    I just updated my theme to bootstrap version "latest" :) theme, I had an older bootstrap - no issues.

    mine was bootstrap 2.2.2 - no issue

    your is 2.3.1 - issue

    and the latest is 2.3.2 - issue

    suggest you post on github for @kasper to fix.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • peregrineperegrine MVP
    edited September 2014

    @swevestah

    you were correct. 2.3.x versions of bootstrap has issues with message count update and checkbox when unclicking.

    where as bittersweet and older version of bootstrap (e.g. 2.2) don't have issue in vanilla 2.1.3

    the issue or a very similar issue was filed before

    https://github.com/kasperisager/vanilla-bootstrap/issues/112

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Fixed in the upcoming Vanilla 2.3 according to Kasper in the issue mentioned above. Here's a temporary workaround by Pajn for Vanilla 2.1.3: https://gist.github.com/andersju/13a4d0736d599f8a8731

    It modifies core files so use at your own risk, beware, etc.

  • @andersju said:
    Fixed in the upcoming Vanilla 2.3 according to Kasper in the issue mentioned above. Here's a temporary workaround by Pajn for Vanilla 2.1.3: https://gist.github.com/andersju/13a4d0736d599f8a8731

    It modifies core files so use at your own risk, beware, etc.

    Edit the indicated file and did not work for me ... I use vanilla 2.1.3 and bootstrap 2.3.2

  • I have the same exact issue installing today, Vanilla (2.1.8p2) with Split/Merge that came with it (1.1) and Bootstrap Theme (2.5.0).

    From what I can gather, it is not registering the select action until I make another action. If I check the checkbox of a comment, nothing happens. If I deselect it again, it says "1 comment selected". If I select two and then deselect one, it says "2 selected" etc etc.

  • This is very strange... If I hard reload, it unchecks all the boxes, but it still says "1 selected". So then:

    • I select one, it still says "1"
    • I select another, it now says "2"
    • I deselect one, it now says "3"!

    (there are only two comments in the thread)

  • Any news about this?

Sign In or Register to comment.