Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Settings saving incorrectly...

edited July 2006 in Vanilla 1.0 Help
In a nutshell, I activated the 'predefined attributes' through the extensions page, then, as directed, went to settings.php?PostBackAction=InstallPredefinedAttributes where I was greeted with a blank page. No probs there, I thought - simply clicked on the settings tab to find the appropriate area to configure my newly installed extension. However, at the top of every page, I saw $Configuration['PredefinedAttributes_INSTALLED'] = '1'; ?> Taking a look at conf/settings.php, it seems that the update has written OUTSIDE of the closing php tag... No probs. I edited settings.php, and ended up switching predefined attributes off - didn't need to know t-shirt sizes... ;) Then I tried to switch the style - installed Soulscape. When the page reloaded, I was greeted by the following at the top of the page: ?>?> Again - stuff I can edit out of settings.php. But what's causing this? I've also got some weirdness going on with the To-Do extension, which I've posted in another discussion (although it's enabled, there's no tab appearing...) - not sure if that's related... Everything else seems to be fine. I'm using Vanilla 1.0. I upgraded from 0.92 last night. Any suggestions/thoughts gratefully accepted! (props and kudos to Mark et al for your work on Vanilla...)

Comments

  • Options
    Update: just tried to switch back to default style, and got this saved to the end of my settings: ?>$Configuration['DEFAULT_STYLE'] = '/themes/vanilla/styles/default/'; ?> While the $Configuration['DEFAULT_STYLE'] line further up in the settings was left unchanged. :(
  • Options
    This is cropping up all over the shop...
  • Options
    Okay - good to know it's not just me. I guess for now, it's not much more than an inconvenience - I can edit the settings file as necessary, and that seems to take care of most of the issues... Strange though - things seemed to be working okay to begin with. Had most of my extensions running as I wanted. Not sure at what point it went askew... (sorry - that's no help for the debugging effort...)
This discussion has been closed.