Please upgrade here. These earlier versions are no longer being updated and have security issues.

Does not show up on 2.1 with latest Bootstrap

This discussion is related to the CreativeCLEditor addon.

As per the author's request:

Tried this with all other plugins disabled, still loads the default editor. 2.1 with Bootstrap.

«1

Comments

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    Ok , I think your problem is this , change this in line 29 of the jquery.cleditor.css

    .cleditorMain {visibility:hidden}

    to this

    .cleditorMain {visibility:visible}

  • That was added so that there is no flickering of the plugin.
    In the cleditor_init.js file, when the plugin is loaded, it will show the editor, with:

    frm.find(".cleditorMain").css('visibility','visible');

    @vrijvlinder‌ but does this happen to you also?

  • @piotrnl does it already work for you?

  • Not as it should: Quotes not visible and inputbox resizes once you start to type.

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    @creativedreams said:
    That was added so that there is no flickering of the plugin.
    In the cleditor_init.js file, when the plugin is loaded, it will show the editor, with:

    frm.find(".cleditorMain").css('visibility','visible');

    vrijvlinder‌ but does this happen to you also?

    Yes, it does not show using bootstrap as the op said. I looked for possible reasons, that one is a big reason. So I suggested they change that part.

  • Hum, it's strange, because I've tested locally and remotely and it worked.
    Only if there is a javascript error from another script that stops the correct procedure of this one, which should be any, other wise other scripts should be also compromise.
    But ok, I will try to another approach to it.

  • peregrineperegrine MVP
    edited October 2014

    .

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    @creativedreams said:
    Hum, it's strange, because I've tested locally and remotely and it worked.

    I am not sure if it was intended but you need to fix all the &$Sender to $Sender

    Looks like you missed two instances and that causes issues with the plugin in 2.1

    peregrine
  • With the suggested edits above it works. Sort of. Quotes doesn't work and I'd like to disable the resizing of the edit-box, once you start typing it resizes to very small, this is unnecessary.
    Ps: Is there a localization file ? I'd like to do the Dutch localization.

  • @vrijvlinder: thanks for the tip. I will take a look at it.

    @piotrnl‌: it all depends how you configured the textarea in the css. If you define a min-height it will maintain the desired height, and then it will autogrow after that.
    But, from your comment, i will also create an easy option to disable the autogrow.
    Cheers

  • Just launched a new version with all those corrections. Please see the plugins webpage to see what's new. Also there's a tip that explains you how you can set a min-height to the editor or to disable the autogrow.

    vrijvlinderpiotrnl
  • Thanks @creativedreams‌

    Does it works on all platforms like ff ie safari etc?

    And how about mobile theme?

    Well, ill give it a try tomorrow.

    Thanks for updating the plugin!!!!!

  • piotrnlpiotrnl New
    edited October 2014

    I've noticed that the insert image url function (thru the button) produces garbage.

    When using the quote function, the cursor is locked in the Quote block. You have to switch to text and then back to WYSIWYG mode to escape the quote block.

  • piotrnlpiotrnl New
    edited October 2014

    update: it's broken:

  • piotrnlpiotrnl New
    edited October 2014

    It breaks when following your tip to add the css to the theme. (Bootstrap).

  • @creativedreams , do you know while in mobile when i want to start typing, the typingscreen closes...?

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    @Schryvers said:
    creativedreams , do you know while in mobile when i want to start typing, the typingscreen closes...?

    This bug has been noted on cleditor and other jquery editors and it is not recommended for mobile use.

  • Can i disable the editor for mobile use only? @vrijvlinder

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    It should already be disabled for mobile by the description in the plugin

    MobileFreindly=FALSE

    But this may not be enough to remove it you need to make sure the mobile theme also removes the unfriendly plugins.

  • peregrineperegrine MVP
    edited October 2014

    edited out.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

Sign In or Register to comment.