HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Usage within full HTTPS environment

Hey SudoCat,

i do like your plugin a much, but i have a problem with it. I want to use it in a full HTTPS secured environment, but getting error because of the external ressources you use.
Could you please remove those external ressources (css and js-files) and make them locally available?


Some errors:
https://platform.linkedin.com/in.js Failed to load resource: net::ERR_BLOCKED_BY_CLIENT
https://apis.google.com/js/platform.js Failed to load resource: net::ERR_BLOCKED_BY_CLIENT
connect.facebook.net/en_GB/sdk.js:56 Invalid App Id: Must be a number or numeric string representing the application id.


  • Options
    SudoCatSudoCat Drowning under a Sea of Clients New
    edited November 2014

    Sorry, totally failed to see this! (Would be really nice to get notifications when someone started a discussion about your plugins!)

    I'm in the process of updating this to work with the next version of Vanilla (which introduces social network embeds), I'll see what I can do about sticking this into the next version.

  • Options
    SudoCatSudoCat Drowning under a Sea of Clients New

    Okay, after having some trawling, I'm not quite sure why you are having these issues. Also, I'm pretty sure that including these files locally would not help, considering they themselves are both being called over SSL already. If there is anything not being called over HTTPS, it'd be a resource which gets called by the javascript files, and thus would not work either way. I'm also pretty certain that if you included them locally, then they would not work properly anyway.

    It's strange, because the errors you've presented indicate more of an issue with API keys, which doesn't make much sense considering none of the social sharing buttons require an API key.

  • Options

    Hey SudoCat,

    thanks for your reply. Did not see your post before, too.
    And now -I dont know why- it is working. Simply re-enabled your plugin and it works. Whatever was the problem: it is gone without changing/upgrading to another version of Vanilla. :smiley:

Sign In or Register to comment.