Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

problem update to 2.1

jackmaessenjackmaessen ✭✭✭
edited November 2014 in Vanilla 2.0 - 2.8

I have tried several times to update my forum from 2.0.18.10 to 2.1 but without success. I keeps hanging on "Failure"
I followed these instructions to update:
http://vanillaforums.org/docs/installation-upgrade
I also put this line into my config.php: $Configuration['Debug'] = TRUE; and it says:
Need to re-index theme cache
Need to re-index plugin cache

How can i make the update possible?

Tagged:

Best Answer

Answers

  • peregrineperegrine MVP
    edited November 2014 Answer ✓

    see the hints: you need to solve the failure issue.

    run /utlitty/structure 7 or 8 times.

    if you don't know how to run /utlitty/structure read this.
    http://vanillaforums.org/discussion/comment/199096/#Comment_199096

    then see these tips and read the discussions links provided in the link
    http://vanillaforums.org/discussion/comment/220293/#Comment_220293

    and it says: Need to re-index theme cache Need to re-index plugin cache

    also this has been answered close to 100 times already.


    if you see this error in the link below - which you may not - but you can solve it as well
    http://vanillaforums.org/discussion/comment/220308/#Comment_220308

    also see:

    http://vanillaforums.org/discussion/comment/220144/#Comment_220144

    if you still have a problem re-read all the links, focus carefully, and see if you missed any steps.

    then after you made an attempt to read the links and follow the instructions in ALL the links, and still have a problem, detail step-by-step what you did. If you say I did "everything" consider that as a non-answer and then post in detail step-by-step what you did and re-read again.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    vrijvlinderjackmaessen
  • @peregrine: i followed these steps above you told me; i did run the query alter table GDN_Tag drop index UX_Tag; after that i did run the **Run structure&data scripts **again en there appears no error anymore.
    So i tried to update again via utility/update in the url and now it says: SUCCESS, the update was successful.
    But below this still is the info:

    Need to re-index theme cache
    Need to re-index plugin cache

    I wrote already a new topic and it works fine.
    I also tried to comment on an existing topic from the old database and it also works fine.
    So thank you very much for support :D

    peregrinevrijvlinder
  • bottom line

    You can ignore the "Need to re-index theme/plugin cache" messages.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

Sign In or Register to comment.