Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Error after upgrade from 2.1.5 to 2.1.6 - How can I solve this?

ProsperProsper ✭✭
edited December 2014 in Vanilla 2.0 - 2.8

I upgraded from vanilla 2.1.5 to 2.1.6.
Update seems to be okay and /utility/update and /utility/structure where successful and showed no errors.
However, when I click on the name of any forum member I get this error below. Profile page shows the error. Edit profile page shows same error.
Please how can I solve this?

Fatal Error in Gdn_Database.Query();

PDO Statement failed to prepare

You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '?' at line 5
The error occurred on or near: /home4/casiegbu/public_html/library/database/class.database.php

288:       if (!is_null($InputParameters) && count($InputParameters) > 0) {
289:          $PDOStatement = $this->Connection()->prepare($Sql);
290: 
291:          if (!is_object($PDOStatement)) {
292:             trigger_error(ErrorMessage('PDO Statement failed to prepare', $this->ClassName, 'Query', $this->GetPDOErrorMessage($this->Connection()->errorInfo())), E_USER_ERROR);
293:          } else if ($PDOStatement->execute($InputParameters) === FALSE) {
294:             trigger_error(ErrorMessage($this->GetPDOErrorMessage($PDOStatement->errorInfo()), $this->ClassName, 'Query', $Sql), E_USER_ERROR);
295:          }
296:       } else {

Best Answer

Answers

  • Options

    I just found out that the problem occur only on the desktop theme and not on the mobile theme. Notification link says "Whoops There was an error". Please I need assistance.

  • Options
    R_JR_J Ex-Fanboy Munich Admin

    Have you altered that theme? Can you post the link that you click?

  • Options
    ProsperProsper ✭✭
    edited December 2014

    @R_J the link is this
    http://naijanetwork.com/profile/3/John
    There is no possible alteration I made to the theme other than updating from Vanilla 2.1.5 to Vanilla 2.1.6

  • Options
    ProsperProsper ✭✭
    edited December 2014

    @Peregrine and @R_J - Thank you guys for your inputs.
    "Following" plugin by @Tim Gunter caused the problem. I have disabled the plugin and issue is solved.

  • Options

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Options

    @peregrine - Thanks

Sign In or Register to comment.