Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Mobile Works Fine, But Nowhere Else?

Vanilla 2.1.6
Centos running Apache on a VPS
Moved my entire Vanilla folder to brand new php-mySQL php5.5 enabled with virtual host listening on port 80. My android mobile phone safari and chrome browsers load what appears to be my vanilla forum completely intact, in both full-site and mobile iterations, in spite of my android tablet and pretty much any other PC in the land getting the bonk message which translates to a 500 internal server error.

I would attempt to reinstall, but when moving a fresh set of folders/files to the server I can't even get to the install page.

I'm stumped.

Geoff

Comments

  • Options

    Oh and I deleted the cache .ini's a bazillion times, and flush my browser caches like a plumber.

  • Options
    peregrineperegrine MVP
    edited January 2015

    post your .htaccess file. and state what folder your vanilla forum resides in.

    also test with the default bittersweet theme.

    you could also try deleting the php files in cache/Smarty/compile

    your description although detailed is like a tongue twister so ...

    then restate in more clear terms

    what works correctly
    _______________________-

    what gives you a 500 error
    ____________________________-

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Options

    you might also post your config.php (but remove any email passwords and keys and other sensitive info).

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Options
    edited January 2015

    .htaccess

    # Modified
    # If you modify this file then change the above line to: # Modified
    <IfModule mod_rewrite.c>
       RewriteEngine On
       # Certain hosts may require the following line.
       # If vanilla is in a subfolder then you need to specify it after the /. 
       # (ex. You put Vanilla in /forum so change the next line to: RewriteBase /forum)
       # RewriteBase /vanilla
       RewriteCond %{REQUEST_FILENAME} !-d
       RewriteCond %{REQUEST_FILENAME} !-f
       RewriteRule ^(.*)$ index.php\?p=$1 [QSA,L]
    </IfModule>
    

    config.php:

    <?php if (!defined('APPLICATION')) exit();
    
    // Conversations
    $Configuration['Conversations']['Version'] = '2.1.6';
    
    // Database
    $Configuration['Database']['Name'] = '(redacted)';
    $Configuration['Database']['Host'] = (redacted)';
    $Configuration['Database']['User'] = '(redacted)';
    $Configuration['Database']['Password'] = '(redacted)';
    
    // EnabledApplications
    $Configuration['EnabledApplications']['Conversations'] = 'conversations';
    $Configuration['EnabledApplications']['Vanilla'] = 'vanilla';
    
    // EnabledPlugins
    $Configuration['EnabledPlugins']['HtmLawed'] = 'HtmLawed';
    $Configuration['EnabledPlugins']['ButtonBar'] = TRUE;
    $Configuration['EnabledPlugins']['Buttons'] = TRUE;
    $Configuration['EnabledPlugins']['Flagging'] = TRUE;
    $Configuration['EnabledPlugins']['cleditor'] = TRUE;
    
    // Garden
    $Configuration['Garden']['Title'] = 'ORM Team Forum';
    $Configuration['Garden']['Cookie']['Salt'] = '(redacted)';
    $Configuration['Garden']['Cookie']['Domain'] = '';
    $Configuration['Garden']['Registration']['ConfirmEmail'] = '1';
    $Configuration['Garden']['Registration']['Method'] = 'Approval';
    $Configuration['Garden']['Registration']['ConfirmEmailRole'] = '4';
    $Configuration['Garden']['Registration']['CaptchaPrivateKey'] = '';
    $Configuration['Garden']['Registration']['CaptchaPublicKey'] = '';
    $Configuration['Garden']['Registration']['InviteExpiration'] = '-2 weeks';
    $Configuration['Garden']['Registration']['InviteRoles']['3'] = '0';
    $Configuration['Garden']['Registration']['InviteRoles']['4'] = '0';
    $Configuration['Garden']['Registration']['InviteRoles']['8'] = '0';
    $Configuration['Garden']['Registration']['InviteRoles']['32'] = '0';
    $Configuration['Garden']['Registration']['InviteRoles']['16'] = '0';
    $Configuration['Garden']['Email']['SupportName'] = 'ORM';
    $Configuration['Garden']['Email']['SupportAddress'] = '(redacted)';
    $Configuration['Garden']['Email']['UseSmtp'] = '1';
    $Configuration['Garden']['Email']['SmtpHost'] = '(redacted)';
    $Configuration['Garden']['Email']['SmtpUser'] = '(redacted)';
    $Configuration['Garden']['Email']['SmtpPassword'] = '(redacted)';
    $Configuration['Garden']['Email']['SmtpPort'] = '587';
    $Configuration['Garden']['Email']['SmtpSecurity'] = 'tls';
    $Configuration['Garden']['InputFormatter'] = 'Html';
    $Configuration['Garden']['Html']['SafeStyles'] = TRUE;
    $Configuration['Garden']['Version'] = '2.1.6';
    $Configuration['Garden']['RewriteUrls'] = TRUE;
    $Configuration['Garden']['Cdns']['Disable'] = FALSE;
    $Configuration['Garden']['CanProcessImages'] = TRUE;
    $Configuration['Garden']['SystemUserID'] = '2';
    $Configuration['Garden']['Installed'] = TRUE;
    $Configuration['Garden']['HomepageTitle'] = 'ORM Team Discussion';
    $Configuration['Garden']['Description'] = 'Secure portal to organizational scheduling and exchange of data. Also a place to unwind with fellow ORM members.';
    $Configuration['Garden']['Logo'] = 'PZ0EMFVX7MSH.jpg';
    $Configuration['Garden']['FavIcon'] = 'favicon_d9089dc9ecd311b5.ico';
    $Configuration['Garden']['InstallationID'] = '(redacted)';
    $Configuration['Garden']['InstallationSecret'] = '(redacted)';
    $Configuration['Garden']['Theme'] = 'default';
    
    // Plugins
    $Configuration['Plugins']['GettingStarted']['Dashboard'] = '1';
    $Configuration['Plugins']['GettingStarted']['Registration'] = '1';
    $Configuration['Plugins']['GettingStarted']['Categories'] = '1';
    $Configuration['Plugins']['GettingStarted']['Plugins'] = '1';
    $Configuration['Plugins']['GettingStarted']['Discussion'] = '1';
    $Configuration['Plugins']['GettingStarted']['Profile'] = '1';
    $Configuration['Plugins']['Flagging']['NotifyUsers'] = array('1');
    
    // Routes
    $Configuration['Routes']['DefaultController'] = 'discussions';
    
    // Vanilla
    $Configuration['Vanilla']['Version'] = '2.1.6';
    
    // Last edited by geoffr (redacted)2015-01-01 02:40:19
    

    I am able to access the forum with both safari and chrome on my android smartphone - with full functionality.

    Thanks for any help,
    Geoff

  • Options

    and state what folder your vanilla forum resides in.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Options

    /vanilla

  • Options
    peregrineperegrine MVP
    edited January 2015

    read this....

    http://vanillaforums.org/discussion/comment/220157/#Comment_220157

    then explain what your problem in simple terms

    also was the an upgrade from 2.0.18.x

    or a totally new install.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Options

    I see now I did not un-comment RewriteBase. I corrected that but still have the same issue.

    My problem, aside from being one of those artistic engineer student-types that likes to get my chops busted in forums from time to time, is this:

    1. I can access the forum via my android smart phone. It doesn't matter which browser I use with my smart phone safari or chrome.
    2. I cannot access the forum from any other device (that I have tried) which includes PC and tablet using chrome, safari, IE 8.

    When I inspect the element in chrome here is the error message:

    Failed to load resource: the server responded with a status of 500 (Internal Server Error)
    When looking at my server error log, there are errors that have nothing to do with vanilla. I can access all other functionality on the website just fine.

    Again, thanks in advance for any help.

    Geoff

  • Options

    also was this an upgrade from 2.0.18.x

    or a totally new install.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Options

    totally new install. I copied the files over to the new server. When I tried to reinstall, I could not get access to the index.php to run it.

  • Options
    peregrineperegrine MVP
    edited January 2015

    I wonder if you are missing any files when you installed.

    I would recopy all the source files over and verify the .htaccess is correct after you re-copy.

    just for grins change this line in your config temporarily.

    it is purely a test to get more info.

    $Configuration['Garden']['Theme'] = 'mobile';

    and report back if you get an error.

    otherwise if you get nowhere

    if you don't care about the user data.

    • just totally erase vanilla folder,
    • and drop the database and
    • start from scratch again on your server.
    • recreate database
    • download core zip file , extract and copy.

    good luck

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Options

    I am in the process of deleting the entire vanilla directory on the server. Before, I just wrote over the old files. I have a hosted database that I think will remain intact, thankfully. Will update progress soon.

    Thanks
    Geoff

  • Options
    peregrineperegrine MVP
    edited January 2015

    the absence or presence of the config.php in the conf folder tells vanilla respectively to start on the installation screen or to assume things are installed.

    i.e. config.php doesn't exist. you will go to installation screen

    existence of config.php that is built properlly - you go to the forum as usual.

    a few people have had issues where they thought they copied all the source files, but because of timeouts etc they missed a few files.

    also check if mod_rewrite exists exists or is loaded in your php modules.

    you can check with php_info

    500 errors could be a result of commands that are in .htaccess that aren't allowed or something you may need to change in php.ini, etc. etc, etc. etc.

    but the problem could be just that you don't have all the vanilla files you need.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Options

    Now it doesn't like my database host.
    SQLSTATE[HY000] [2005] Unknown MySQL server host

    It was fine with the host before. I even created a new database to see if that was the issue.

  • Options

    Apache/2.2.22
    Database client version: libmysql - mysqlnd 5.0.10

  • Options
    peregrineperegrine MVP
    edited January 2015

    what is the value in your config.php for host.

    verify it is what you think it should be.

    $Configuration['Database']['Host'] = 'localhost';

    then you could also verify the username and password via phpmyadmin

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • Options

    localhost is the default. I populated that field with my db host url (with the hosting service) I am thinking because of the hosted db firewall, it is refusing the connection from my VPS because the VPS is with a different hosting company.

    Are you saying that I should just create my own mySQL and have it reside in the root of my VPS?

  • Options

    my original site was hosted by the same company that hosts the database server. Then I moved everything to the VPS.

  • Options

    I am dispensing with the remote db host and installing mySQL on the localhost. will update progress directly.

  • Options

    I'm live. I was able to export the hosted database to a .sql file and then import it to my pre-configured localhost mySQL server on my VPS. Should have done this a long time ago. This particular forum will experience at most micro-traffic, so I am not worried about resource consumption.

    I think the problem all along was permissions into the hosted database server from my VPS (different hosting service). Vanilla wasn't getting access from its new location. Thanks a ton for your help!

    Geoff

Sign In or Register to comment.