Warning: Not compatible with Vanilla 2.1 (yet).

This discussion is related to the Emoji Pro addon.
peregrineperegrine MVP
edited January 2015 in Feedback

the plugin says in the description. why it not work. when will it work? is the vanilla core the issue, or just that the plugin is not updated.

I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

Comments

  • phreakphreak VanillaAPP - White label iOS and Android App MVP

    I'mm also interested in using emojis in my forum. Does 2.2 deliver (doesn't seem so) or will this be always a plugin sided enhancement?

  • peregrineperegrine MVP
    edited August 2015

    edited:

    plugin abandoned. feature replaced by core . see comment below.

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • @phreak said:
    I'mm also interested in using emojis in my forum. Does 2.2 deliver (doesn't seem so) or will this be always a plugin sided enhancement?

    It does. They is a standard set of emoji (the ones similar to Apple) in the core, but 2.2 ships with the EmojiExtender plugin which lets you switch out the sets easily.

    It comes with 5 sets already, but you can also add your own sets with a plugin:

    public function emojiExtenderPlugin_init_handler($sender) {
        $path = '/plugins/myemojiset/myemoji';
        $sender->addEmojiSet('myemoji', PATH_ROOT.$path.'/manifest.php', $path);
    }
    

    addEmojiSet takes 3 parameters: the name of the set, the absolute path to the manifest.php and the asset path where the images are.

    My themes: pure | minusbaseline - My plugins: CSSedit | HTMLedit | InfiniteScroll | BirthdayModule | [all] - PM me about customizations

  • phreakphreak VanillaAPP - White label iOS and Android App MVP

    @Bleistivt: Yes, i'm using the "Emoji Sets" plugin. Only Problem the Advanced Editor is only showing 12 Smiles/Emojis.

    1 - Does anyone if it is possible to show more here?
    2 - Adding Emojis via my iPhone Safari browser and sending a comment just strips the Emojis out. Is there a workaround for this?

  • jamesincjamesinc Sydney ✭✭

    As far as I've seen, Vanilla 2.2 insists on messing with Emojis, including these custom emoji sets (which capture what like 5% of the emoji sets on most mobiles?). Can I set it up so that it just converts Unicode emojis to HTML entities and leaves them alone after that?

  • @jamesinc Enable the "Emoji Sets" plugin and select "None" in its settings.

    My themes: pure | minusbaseline - My plugins: CSSedit | HTMLedit | InfiniteScroll | BirthdayModule | [all] - PM me about customizations

    hgtonightjamesinc
  • jamesincjamesinc Sydney ✭✭

    @Bleistivt thanks!

  • jamesincjamesinc Sydney ✭✭

    Hmm okay, so now it just acts weird. I made a test comment with some emoji, a smiley, then I think a santa claus and a devil, and only the smiley displays (on any device), and in the DB itself I can see only the smiley is being captured and that it has not been converted to an HTML entity.

    nesttle
  • Same here.

    When editing a post, Emoticons not showing properly (with and without Emoji Set).

    Thread view:

    Editing:

    Editing (html view):

    Also, I'm using YAGA and all Ranks have "Format Emoticons" enabled:

Sign In or Register to comment.