Users running a non-download version of Vanilla (pulled from github), on branch release/2019.016 or master from the last 2 weeks should upgrade to release/2019.017 or latest master for security reasons. Downloaded official open sources releases are not affected.
Please upgrade here. These earlier versions are no longer being updated and have security issues.

302 after setting up wrong route

R_JR_J Cheerleader & TroubleshooterMunich Moderator

I have made my test installation unusable by messing around with routes. In the dashboard, I tried adding a route for /entry /signin with a 302 but I did it completely wrong and got an unresolvable loop at /entry/signin?Target=entry%2Fsignin.

a) So I deleted that route line from my config.php and expected that everything would be alright, but the loop still was there. I laughed at myself because I forgot to delete the ini files, but to my surprise, deleting them did not change anything!

b) I have adminer in one other subfolder of the same domain, and that's why I thought "If I can't fix it, I will avoid it!" and I simply renamed the directory, changed the nginx config to point to the new folder, restarted it and cleared the cache. I've tried that two times already, but there's still no change. My access log is full of lines like that: ... "GET /VaTe/entry/signin?Target=entry%2Fsignin HTTP/1.1" 302 5 "-" "Mozilla...

c) I've downloaded current 2.1 again and copied it over to my installation. No effect.

I have no idea why that is happening and why I can't solve that. b) made me think that it must have something to do with my Vanilla installation, but then c) must have solved it.

Does anyone has any clue?


Comments

  • It is happening in your browser clear your cache.

    grep is your friend.

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    I've already tried to access my site also another browser over a VPN proxy and with my mobile. They all have that problem.

    I wouldn't expect browser cache to generated 302 entries in my access log, but that's just an assumption because I do not much about http requests.

    If it were a Windows server I would reboot it... :(


  • well are you using any kind of object caching?

    grep is your friend.

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    Oh, what I haven't mentioned yet: I changed the RewriteUrl entry in the config.php to "false" and then I got redirected to "/index.php?p=/entry/signin&Target=entry%2Fsignin" when I simply tried to open the homepage.
    Not sure what that means, but it sounds important. To me this is a sign of Vanilla doing the redirection


  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    I have OpCache and memcached, but config.php is excluded for Opcache.


  • try clearing you memory cache and restarting the server.

    grep is your friend.

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    Oh man! I simply had a corrupt (self produced) plugin! I should have followed the advise to deactivate all plugins and reactivate them one by one :(

    Thanks, @x00! I was convinced that error had something to do with my tests on the route...


  • did you actually save the config file?

    grep is your friend.

Sign In or Register to comment.