Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Installation Forum

edited July 2006 in Vanilla 1.0 Help
Hi, I think I installed good the Forum.. But, they are : On Top : Warning: session_start() [function.session-start]: open(/mnt/123/free.fr/4/3/blocar/sessions/sess_7e082269d110c0ed04cc1cb55cc07f36, O_RDWR) failed: No such file or directory (2) in /mnt/123/free.fr/4/3/blocar/Vanilla/library/People/People.Class.Authenticator.php on line 93 Notice: session_start() [function.session-start]: ps_files_cleanup_dir: opendir(/mnt/123/free.fr/4/3/blocar/sessions) failed: No such file or directory (2) in /mnt/123/free.fr/4/3/blocar/Vanilla/library/People/People.Class.Authenticator.php on line 93 On Down : Warning: Unknown(): open(/mnt/123/free.fr/4/3/blocar/sessions/sess_7e082269d110c0ed04cc1cb55cc07f36, O_RDWR) failed: No such file or directory (2) in Unknown on line 0 Warning: Unknown(): Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/mnt/123/free.fr/4/3/blocar/sessions) in Unknown on line 0 Please say me how I can repare this. The URl of my site : http://blocar.free.fr/Vanilla/ I'm sorry for my English, I'm French. Bonjour, j'ai installé le Forum sur mon site, et il ne marche pas, il y a des "Warning..." (cf URL au dessus ) Silvousplait, expliquez-moi comment réparer ... :(
«1

Comments

  • Options
    Looks like you have something wrong with the permissions on your server. Probably best contacting your host for support.
  • Options
    You need to create a directory called "sessions" at the root of your web directory. Il faut que tu crées un répertoire nommé "sessions" à la racine de ton répertoire web. :)
  • Options
    edited July 2006
    Merci, j'essaye de suite =D. Edit : Ca ne marche toujours pas :(. It is not working...
  • Options
    edited July 2006
    Comme la dit Minisweeper, le problem vient de free.fr. Demande leur de regler le probleme.

    (je ne sais pas ou tu as place "sessions", mais je suppose tu n'as pas acces a /mnt/123/free.fr/4/3/blocar/).
  • Options
    Is your new directory "sessions" at the root of your web space, I mean not under the vanilla folder? Did you set the permissions to 777? As-tu bien créé le repertoire "sessions" à la racine de ton espace web, et pas dans le repertoire de Vanilla ? As-tu donné tous les droits (777) ?
  • Options
    oups, j'aurais du mieux le message d'erreur, session dois etre dans le docroot (?????).

    C'est toujours quelques chose que ton provider devrais regler pour toi. Le repertoire "sessions" ne devrais pas etre dans le docroot et tu ne devrais pas avoir deviner ses droits (777 etant une mauvaise solution).
  • Options
    D'accord, je vais demander à Free.fr >.<, mais je crains que ça ne mette pas mal de temps... remouk, oui, je l'ai mit sur mon Espace Web. Avec FileZilla... Quand je mets les tous les Droits et que je clique sur "Ok", si je re-regardes les Droits, ils sont remis à 700. C'est normal ? Dinoboff, c'est quoi le docroot ? C'est pas grave de toute façon, je vais demander à Free.
  • Options
    remoukremouk New
    edited July 2006
    Merci de nous tenir au courant si tu trouves une solution. :) De mon côté, dès que j'ai un peu de temps libre j'essayes d'installer Vanilla sur un compte free.
  • Options
    edited July 2006
    Merci =D. Je vais tous vous prévenir si ils me répondent.
  • Options
    I need subtitles. :)
  • Options
    Same here!
  • Options
    remoukremouk New
    edited July 2006
    Ok, subtitles: it doesn't work yet so he will contact his host. By my side, I'll try to install Vanilla on the same host (don't know when yet) to try to see what's happening. Of course, we will post a comment IN ENGLISH when it will be resolved. ;)
  • Options
    edited July 2006
    Sorry tovio, but that just what Minisweeper said, this kind of session problem need to be solved by the sys admin.


    ps: Is this forum canadian? Could it have two official languages?
  • Options
    I forgot canadian people spoke french. But it's an 'english' forum. While mark is canadian (he lives there, atleast, I dont think he was born there, i might be wrong), i'm 99% sure he doesnt speak french. And he's a bit worried about setting up support forums in other languages cause it's much more difficult (impossible) for him to moderate them. Good to see people helping out though even if i have no idea what's going on!
  • Options
    edited July 2006
    Voilà ce que m'a dit le méchant :( ( blocar = Tibogoeth ) : Bienvenue sur le Chat de la hotline Free. Posez votre question, un conseiller va vous repondre t-chat008: Bonjour et bienvenue sur le chat de Free blocar: Bonjour, j'ai un problème avec mon Espace Perso t-chat008: nous ne faisons pas de support sur les pages perso, tout ce ci etant de votre responsabilité, par contre si c'est un probleme d'acces a votre espace par FTP, je peux vous renseigner blocar: Heu, mais je fais comment alors ? blocar: Ce n'est pas un problème d'accès. blocar: Il y a "Warning...." blocar: Voilà, il y a ça : blocar: Warning: session_start() [function.session-start]: open(/mnt/123/free.fr/4/3/blocar/sessions/sess_90b02d145b4513eb604cf37e8f2239e1, O_RDWR) failed: No such file or directory (2) in /mnt/123/free.fr/4/3/blocar/Vanilla/library/People/People.Class.Authenticator.php on line 93 t-chat008: oui c'est probleme de PHP sur vos pages t-chat008: a vous de verifier votre codage blocar: Et d'autres. Vous ne savez pas à qui je peux demander de m'aider ? blocar: C'est un Forum tout préparé, j'ai demandé aux autres, et personnes n'ont ce problème t-chat008: c'est un forum PHPBB2? blocar: Non, Vanilla : http://getvanilla.com/ http://lussumo.com/community/ t-chat008: quelque soit le forum, s'il est preinstallé t-chat008: vous devriez trouver des informations sur le site officiel t-chat008: comme pour les forums phpbb2 justement blocar: Les personnes qui m'ont répondu m'ont dit de demander à mon Hébergeur t-chat008: cela n'a pas de lien avec votre hebergeur t-chat008: il y a juste une erreur dans le codage des pages t-chat008: nous ne vous fournissons qu'un espace de stockage sur notre serveur blocar: Mais, je suis le seul à avoir ce problème... t-chat008: et rien de plus blocar: ... blocar: Bon, okay, je vais voir tout seul... Sorry, I can't translate...
  • Options
    Oh, very thank you ! Remouk says me the same idea, I did it, add sessions at the root of my Web Space, but those Warning are here.
  • Options
    I know, just to say that he was on the good way... you have to create the session folder; and the problem come from free.fr

    See this other post chmod "locked" by hosting at 700 and 644 : possible to run MODx ?
  • Options
    edited July 2006
    Thanks for this URL, but I don't understand a lot of their English. What is MODx ? And now, I know why I can't change permissions... How can I really change, now ? I send an e-mail to Free.
  • Options
    edited July 2006
    Seems to be a cms... I was looking for the same problem with installing others application on free. Forum, wiki, cms... All have the some problem with free.fr.
    Most of time the solution with this provider is to create a repertory "sessions". Don't know why it is doesn't work for you.
    Maybe try over permissions like 730 or 330 for sessions.
    Or create a repertory "sessions" in the vanilla repertory; replace line 93 of People.Class.Authenticator :
    if (!session_id()) session_start();byif (!session_id()) { session_save_path($this->Context->Configuration['APPLICATION_PATH'] . 'sessions'); session_start(); }
This discussion has been closed.