Installed locale not showing even though it is enabled

tpdtpd New
edited February 2015 in Localization

Hi,

I installed Japanese locale (http://vanillaforums.org/addon/vf_ja-locale), enabled and set it as default it in Dashboard but it is not appearing on forum main page. Do you have any suggestions on what I could be doing wrong? I am running a self-hosted version of Vanilla, v2.1.8p1.

Thanks!

ChathinduSL

Comments

  • Try clearing the .ini files in the /cache directory

    My themes: pure | minusbaseline - My plugins: CSSedit | HTMLedit | InfiniteScroll | BirthdayModule | [all] - PM me about customizations

    hgtonight
  • I tried clearing out the .ini files, but Japanese UI text is still not showing. Any other suggestions?

  • Has anyone have successfully installed and run a non-English locale on a self hosted version? I'm wondering if it is the locale files issue...

  • AnonymooseAnonymoose ✭✭
    edited February 2015

    @tpd said:
    Has anyone have successfully installed and run a non-English locale on a self hosted version? I'm wondering if it is the locale files issue...

    Yes. Add a line with your locale definition to /conf/config.php

    $Configuration['Garden']['Locale'] = 'en-US'; $Configuration['EnabledLocales']['YourForumName'] = 'en-US';

    Change YourForumName to your forum name, and en-US to the locale you want.

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator
    edited February 2015

    Normally there are no problems.

    1. enable the language pack
    2. choose it as default
    3. maybe you have to clear the ini files in /cache

    That's it.


  • Thanks everyone for your advise. I tried the suggestions offered so far but Japanese UI text is still not showing up. I see a directory that is in /applications/vanilla/locale, and it only has en-US in it. Should the locale files be uploaded to that instead of /locale? Maybe wrong file permissions? I wonder if there is a way to run Vanilla in debug mode....

  • I installed Vanilla through MojoMarketplace. Maybe that's the problem...

  • It works without a problem for me, I just tested it.

    And yes, you can run vanilla in debug mode by adding this to your conf/config.php

    $Configuration['Debug'] = TRUE;
    

    But I doubt it will help with your locale problem.

    My themes: pure | minusbaseline - My plugins: CSSedit | HTMLedit | InfiniteScroll | BirthdayModule | [all] - PM me about customizations

  • @Bleistivt, when you extracted the files, did you just upload the files in vf-ja folder and the folder itself to /locales? Or did you upload the one level up with version number?

  • So it turns out that I needed to uncompress the zip file right in the /locale directory on the server. I was uncompressing locally on a folder on my machine, and then uploading it. Learned a lesson here. :)

    Bleistivt
Sign In or Register to comment.