Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Subdomain Problems during Upgrade to Vanilla 1

edited July 2006 in Vanilla 1.0 Help
i just upgraded to the new vanilla 1... however, i'm having some problems with the subdomain that previously worked seemlessly. i have a subdomain set up for vanilla, which points to a directory on my main domain: http://myserver points to http://myserver/interact i upgraded using the main directory, imported my old settings (which had worked fine with the subdomain) and now I am only able to access vanilla from the main directory. i tried tinkering with the settings of directories in "settings.php" by nothing seemed to jive. it's interesting because i get an unformatted version, and no ability to login with the subdomain: http://vanilla.myserver any ideas?

Comments

  • Options
    Can you paste the relevant sections (web/app paths and cookie settings) from your appg/settings.php file?
  • Options
    edited July 2006
    this is what's in my settings.php in "conf" folder... (i thought settings.php shouldn't be editted in the "appg" folder- should i edit those settings?) $Configuration['APPLICATION_PATH'] = '/home/passenger/www/interact/'; $Configuration['DATABASE_PATH'] = '/home/passenger/www/interact/conf/database.php'; $Configuration['LIBRARY_PATH'] = '/home/passenger/www/interact/library/'; $Configuration['EXTENSIONS_PATH'] = '/home/passenger/www/interact/extensions/'; $Configuration['LANGUAGES_PATH'] = '/home/passenger/www/interact/languages/'; $Configuration['THEME_PATH'] = '/home/passenger/www/interact/themes/vanilla/'; $Configuration['DEFAULT_STYLE'] = '/interact/themes/vanilla/styles/default/'; $Configuration['WEB_ROOT'] = '/interact/'; $Configuration['BASE_URL'] = 'http://www.myserver/interact/'; $Configuration['FORWARD_VALIDATED_USER_URL'] = 'http://www.myserver/interact/';
  • Options
    For me it's the other way round - i get a formatted login page with the subdomain, and no formatting on the /interact/ folder. Can you just confirm which way round it is for you?
  • Options
    well, i just reinstalled it from the subdomain, so now it's the other way around: formatted and functional at the subdomain, but unformatted and unfunctional at the /interact/
  • Options
    Interesting. I've a feeling you might have difficulty achieving this then. I cant think of a way to make those paths work both ways. Is there a reason you need to access from both URIs?
  • Options
    I guess I don't really need to... i just thought if it was something simple it would be nice to have it work at both urls...

    I guess I could do a < meta refresh > to point to the other directory...
  • Options
    Yeah. I'm sure someone will come along and tell me I'm wrong but right now i cant think of anything. If you could stand by and fan me for a while while i think it might help. *melts
  • Options
    If there is no real reasons for doing it. you should just make you forum works on http://interact.passengerproductions.com

    And add in the virtualhost directives for www.passengerproductions.com "Redirect 301 /interact http://interact.passengerproductions.com"

    Like that if you have an other apps for your website, they won't share the same domain, what can lead to security issue if they don't share the same session manager system.
This discussion has been closed.