Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Vanilla Importing error

edited March 2015 in Vanilla 2.0 - 2.8

I have exported from (using the latest vanilla porter) and am now trying to import to a fresh install of 2.1.8p2

The import is progressing but at stage 9 (Insert Tablets) it returns an error reading;
{"Code":403,"Exception":"You don't have permission to do that.","Class":"Gdn_UserException"}

are there permissions somewhere I should be changing?

EDIT: uhhh, nevermind. refreshed the import page a few times and it went through. so problem solved i guess?



  • Options
    rasteronrasteron ✭✭

    hey @Rajio try checking and make sure that all features are working, toggle themes and plugins, etc.

  • Options

    @Rajio don't use the porter for upgrading your forum, follow the upgrade instructions in the README

    Upgrade an importing are completely different things and should not be confused.

    grep is your friend.

  • Options

    @x00 thanks. I know its not proper procedure but I tried upgrading a few times and had no luck - when i'd upgrade my messages and users would be gone and it would look like i was starting from scratch. i couldn't see how to solve that (granted im no expert) so i thought i'd try a fresh install of the latest version and port over the bits i really wanted to keep (users, messages, etc) ... ive got that working now so we're all good. I've just got to go through and confirm that everything is working like @rasteron said. This may be insane but i figured it would give me an opportunity to clean things up a bit anyhow.

    If there is some major problem I'm inadvertently walking in to, let me know but from what i can see now everything seems great. In the future I'll go back to the usual upgrade methods as obviously thats less work in general. this is the first upgrade that gave me real issues.

Sign In or Register to comment.