Users running a non-download version of Vanilla (pulled from github), on branch release/2019.016 or master from the last 2 weeks should upgrade to release/2019.017 or latest master for security reasons. Downloaded official open sources releases are not affected.
Please upgrade here. These earlier versions are no longer being updated and have security issues.

I have installed Vanilla CMS and tried to enable the application then its bonked

edited April 2015 in Vanilla 2.0 - 2.8

Something has gone wrong.

We've run into a problem and are unable to handle this request right now.
Please check back in a little while.

Tried to enable the debug even then the same message is coming and no debug trace as well. I am using fresh installation of vanilla 2.1.9

Tagged:

Comments

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    Try those steps one by one and you
    a) will see the actual error and
    b) might be able to solve the problem yourself or
    c) report the error here to get help


    hgtonight
  • Thanks R J and will try these steps

    hgtonight
  • x00x00 MVP
    edited April 2015

    Are you talking about this?

    http://vanillaforums.org/addon/vanillacms-application

    I don' think it is 2.1 compatible.

    You might be interested in

    http://vanillaforums.org/addon/articles-application

    grep is your friend.

    venkatreddycShadowdarehgtonight
  • Great. How do i remove this Vanilla CMS app and database content

  • Removed the Vanilla CMS app and tried to debug from the index.php and its failing at ob_start()

    define('APPLICATION', 'Vanilla');
    define('APPLICATION_VERSION', '2.1.9');

    // Report and track all errors.

    error_reporting(E_ERROR | E_PARSE | E_CORE_ERROR | E_COMPILE_ERROR | E_USER_ERROR | E_RECOVERABLE_ERROR);
    ini_set('display_errors', 1);
    ini_set('track_errors', 1);

    echo "Test 01";

    ob_start();

    echo "Test 02";

    // Define the constants we need to get going.

    define('DS', '/');
    define('PATH_ROOT', getcwd());

    // Include the bootstrap to configure the framework.

    require_once(PATH_ROOT.'/bootstrap.php');

    // Create and configure the dispatcher.

    $Dispatcher = Gdn::Dispatcher();

    $EnabledApplications = Gdn::ApplicationManager()->EnabledApplicationFolders();
    $Dispatcher->EnabledApplicationFolders($EnabledApplications);
    $Dispatcher->PassProperty('EnabledApplications', $EnabledApplications);

    // Process the request.

    $Dispatcher->Start();
    $Dispatcher->Dispatch();

  • @R_J said:
    Try those steps one by one and you
    a) will see the actual error and
    b) might be able to solve the problem yourself or
    c) report the error here to get help

    RJ tried the steps listed but still no useful log and bonk error

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    Maybe you have tried something like that before and now your installation is completely broken? I would try to copy all files again to the Vanilla installation. You would only have to take care for your .htaccess file if you have changed anything there.

    If the error still prevails, you might have activated another plugin that raises the error. And we really need to see any kind of error message in order to help ;)


    venkatreddyc
  • x00x00 MVP
    edited April 2015

    get the echo stuff out of there. tell me when it fails what status code do you get?

    http://httpstatus.io/

    You should check your server logs for errors.

    grep is your friend.

    Shadowdare
  • Tried all possible steps and there are no traces available. Any other solutions

Sign In or Register to comment.