Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

No new plugins are showing up after I dragged them to the plugins folder [SOLVED]

edited April 2015 in Vanilla 2.0 - 2.8

I am placing them in the correct folder but they are not showing up



  • whu606whu606 I'm not a SuperHero; I just like wearing tights... MVP

    What did you drag?

    Did you unzip them first?

    Which plugins have you tried?

  • teamspeak-server-plugin and online now they both were unzipped.

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... MVP

    So they don't appear in the Dashboard?

    What about under the disabled tab?

  • under all, and disabled they are not listed

  • R_JR_J Ex-Fanboy Munich Admin

    I guess it has something to do with Vanillas Plugin Cache and a caching misconfiguration. I was to lazy to solve the problem, but I have made a plugin which helps me in such cases:

    <?php defined('APPLICATION') or die();
    $PluginInfo['ClearPluginCache'] = array(
        'Name' => 'Clear Plugin Cache',
        'Description' => 'Clears plugin and config cache on every enable/disable of this plugin.',
        'Version' => '0.1',
        'Author' => 'Robin Jurinka',
        'License' => 'MIT'
    class ClearPluginCachePlugin extends Gdn_Plugin {
        public function setup() {
        public function OnDisable() {

    Enabling or disabling clears Vanilla plugin cache which will show you all plugins with correct information.

    Your problem now is that you wouldn't be able to enable it! =)

    So add

        public function base_render_before() {

    to any of your currently enabled plugins and delete it right after you've reloaded any of your forums pages.

    If that doesn't help, I'd assume your problem has something to do with file access rights...

  • R_J How do I enable the plugin in the first place if no plugins show?

  • x00x00 MVP
    edited April 2015

    Have you checked the file permissions of the folders and contents?

    Sometimes the obvious is worth checking before goign on a wild goose chase.

    grep is your friend.

  • yea I set the new plugins to 744

  • @darkmdbeener said:
    yea I set the new plugins to 744

    and the contents of the folders?

    grep is your friend.

  • You may need to 755 on some systems.

    grep is your friend.

  • edited April 2015

    I used Filezilla to make the whole folder 744 ill try 755

    still a no go.

  • x00x00 MVP
    edited April 2015

    in cache delete files the end in .ini

    make sure conf/config.php file is writeable.

    grep is your friend.

  • cache is empty and conf is 775

  • edited April 2015

    @darkmdbeener said:
    cache is empty and conf is 775

    im an idiot wrong cache >.>

    Still not showing up.

  • well what is the contents of these folders?

    grep is your friend.

  • what sort of hosting package are you on?

    I wonder if the directory truly reflects what is running on the server.

    grep is your friend.

  • 1and1 unlimited installed in free mode.

  • Did you install Vanilla through a script? Not a fan, you are better of installing it following the installation instructions from the horse's mouth.

    grep is your friend.

  • yea >.> I might just have to do that seeing as I can not get it to work this way if it does not work still ill flip my proverbial table.

Sign In or Register to comment.