Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Internal error, could not save the file. - "Uploader"

GilEstelGilEstel New
edited April 2015 in Vanilla 2.0 - 2.8

I've installed the Uploader Plugin in the plugins folder as described. The uploads folder has recursive permission 777.
I've added the permissions for my User (see attachement).
Additionally I added a php.ini into the vanilla root folder with the content mentioned above.

Nonetheless I get the error that the file can't be saved. Please Help!

Best Regards
GilEstel

Comments

  • The file I tried to upload was a pdf of 40 kb and of course this filetype is listed in the allowed file types for the plugin...

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    Ok, this does not happen on my installs. Try using another browser or see if you get some kind of error beside the message. I can upload without any trouble at all.

    Don't leave that php.ini file in the forum folder unless you are allowed to do it by the host or you are on a local machine. That only helps if you can't upload very large files.

  • GilEstelGilEstel New
    edited April 2015

    Thank you for your fast response! =)
    I tried it with firefox and it didn't work either. Normally I work on Chrome. But what I found out is, that it seems that I don't have enough permissions to change the directory properties recursiveley for the uploads directory. So uploads itself has 777 and below only 755 and I can't change this. Could this be the problem?

    Attached there is a print of the error message:

    I also tried to change the filename, assuming it was too long or contained characters which might cause the error.
    [EDIT] I've also tried other filetypes like txt or docx, same there [/EDIT]

    Is it possible to change the path to where the files are stored? There are no error messages in the java console. Where could I find something informative?

    Best Regards

    GilEstel

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    Your issue is something other than this plugin. If you can't upload anything. The uploads folder has 775 in my setup. Internal error means something with your setup or server or file ownership is wrong.

    This plugin works perfectly well. You need to look at your cgi error logs and find the cause. It could be another plugin or something else.

    Try FileUpload plugin.

Sign In or Register to comment.