Please upgrade here. These earlier versions are no longer being updated and have security issues.

FeedDiscussions not working in Vanilla 2.1.9?

This discussion is related to the Feed Discussions addon.

My FeedDiscussions-Plugin is not working. I have a newly installed Vanilla 2.1.9 and uploaded FeedDiscussions to the plugins-Folder. It shows up in the Admin panel and I added some feeds which are all accepted, but they are not updated. Old feed entries are also not imported, even though I checked this option.

I read in http://vanillaforums.org/discussion/26887/feed-entries-not-posting-to-forums#latest that there appeared a problem when upgrading from 2.1.8 to 2.1.9. Does anybody know how one gets FeedDiscussions working in 2.1.9?

Comments

  • I tried to look for the error myself but do not find anything in the Apache error.log. Can somebody give me a hint how I can debug the plugin?

  • vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited April 2015

    Try this plugin it works better although not perfect. The category is not easy to set from the dashboard so it is set to general category which you can change later to other categories. The user is set to be the System account.

  • Thank you very much. I insalled this file MagpieFeeds. I obtained the categoryID from the sql database and registered some feeds. When I update manually a blank page is shown and new update times are displayed for the registered feeds in the plugin configuration. But unfortunately, no posts are created. I don't see any error messages. Also, sometimes the categoryID is undefined after registering a feed.

    What can be the reason for no posts being imported? I already tried several feeds?
    Where can I set the categoryID manually? I don't see any configuration file?

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    It all depends on the feed. I make my feeds using feed burner .

    Try this feed http://feeds.feedburner.com/OceanImages

    I recommend that you use the general category and System user. The possible reasons why a feed may not post is, the feed is not a good feed, the category does not exist or the user does not exist.

    What shows in the dashboard as far as the settings, does not work too well, I am still sorting that out. But it does post feeds. I have 55 pages of feeds posted on a forum.

    The quality of the feed depends entirely on the way the feed is fed by the source of the feed not the plugin.

  • http://feeds.feedburner.com/OceanImages does not work either.
    I now figured out that one can put Vanilla in Debug mode and received the following notice when the plugin does the update:

    Notice: Undefined variable: FormPostValues in ...htdocs/plugins/MagpieFeeds/class.magpiefeeds.plugin.php on line 72

    hgtonight
  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    That variable is defined by the user selected in the dashboard. You can bypass that by adding the UserID by hand there if you want to try it.

    $FeedData['UserID'] = "2";

    $FeedData['CategoryID'] = "1";

    That part only affects the dashboard output where it shows you the saved feed.

Sign In or Register to comment.