Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product
Please upgrade to 2.3 here. The 2.2 and earlier branches are no longer being updated.

Wrong wordpress registration link

This discussion is related to the Vanilla jsConnect Auto SignIn addon.
canadiencanadien New
edited April 2015 in Vanilla 2.0 - 2.3

Have been successfully using this great plugin for some time. I am using the HideConnectButton and HideSignIn feature. But I just realized that when you are logged out, click on any discussion, you are offer to register at the bottom. The problem is that the registration link is wrong even if it is properly set in the wordpress vanilla plugin settings. And I can't find a way to edit the link.

Any light would be appreciated. thx

Comments

  • Not really sure what you mean, do you have a link?

    grep is your friend.

    hgtonight
  • canadiencanadien New
    edited June 2017

    @x00, please excuse me: I just realized I forgot about this thread, but I still have the problem.

    Here is the link http://www.energympro.com/forum/

    Even leaving the red registration button on top will lead to the wrong link structure.

  • HI Canadien, I ran into this issue with my CodeIgniter embed / SSO implementation.

    The issue has to do with pretty URL's.

    FYI, I did some URL testing.. you can get to your registration page by doing:
    www.energympro.com/forum/register?Target=discussions

    However, not sure that completely solves your problem.

    but, you may want to try putting:
    /register?Target=discussions

    In your register URL, instead of:
    /vanilla/entry/register?Target=discussions

    Another thought.. In my config file, I set a config as /forum/ since the forum was embeded into that directory. You may want to check that you have done the same. However, after doing that, it may be that the register URL above that I found will have changed slightly.

    Donovan

  • Btw, I was able to register to your forum using that URL.. but the Target did not bring me back. For the target, you may want to use a full domain, including the http://... that is, if query strings are even allowed.. if not, you may have to allow them.

  • canadiencanadien New
    edited June 2017

    @donovanb a dit :
    but, you may want to try putting:
    /register?Target=discussions

    In your register URL, instead of:
    /vanilla/entry/register?Target=discussions

    Thanks for your input donovanb. If you are talking about the jsconnect settings, yes indeed that is the link I already have.

    As for config file, my registration is set to connect:
    $Configuration['Garden']['Registration']['Method'] = 'Connect';

    So right now I still don't see where the problem may lay.

    BTW I'd be interested to see how your forum works, if you may?

  • Since you have your forum embeded, what do you have in your .htaccess file for 'RewriteBase'?

    I had to comment out the following as well, for mine to work right:

    # RewriteCond %{QUERY_STRING} ^p=/?([^&]+)(&([^?]+))?$
    #  RewriteRule ^index\.php %1?%3 [E=X_REWRITE:1,L]
    

    Regarding a link.. our Vanilla forum is not yet live.. waiting for the 'okay' from our Editor.

    Donovan

Sign In or Register to comment.