Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Greek Translation

edited July 2006 in Vanilla 1.0 Help
I've just created a greek translation for the Vanilla and tried to apply it in one of my installation but it didn't seem to work. All characters appeared as question marks and I had to set language to NONE to restore the functionality of the site.
I've change this parameter
$Context->Dictionary['XMLLang'] = 'el';
in the "definitions.php" file but no good...Any other advices????

Comments

  • Options
    lechlech Chicagoland
    edited July 2006
    I just did a quick hunt, I think you want:
    $Context->Dictionary['XMLLang'] = 'el-Latn';
    to render correctly. Otherwise try el-GR
  • Options
    First of all thanx for the answer. I tried both solutions but didn't work. The page is full of Questionmarked characters.
  • Options
    "this line is from headers.php file. i hope this works. you all guys have version 1.0? header ("content-type:text/html;charset=utf-8");" taken from this thread: http://lussumo.com/community/discussion/2071/?Focus=26185 You may need to change the charset
  • Options
    I didn't think about changing the charset in header.php...propably that's the problem. I will try it and get back to you!
  • Options
    I've found that line of code in file "settings.php", that probably causes the problem of the Greek characters:
    $Configuration['CHARSET'] = 'utf-8';

    and I tried to change it in the characterset that I usually set when I create web sites in Greek, which is:
    $Configuration['CHARSET'] = 'iso-8859-7';

    But when I did that I got the following error message all over the page...
    Warning: htmlspecialchars(): charset `iso-8859-7' not supported, assuming iso-8859-1 in /hsphere/local/home/dummwiam/kastaniani.gr/forum/library/Framework/Framework.Functions.php on line 370
This discussion has been closed.