HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Vanilla 1.5.1 How to change sign in url

Apologize if this sounds out of the way since i am still using Vanilla 1.5.1, (somehow never updated, if it aint broken why fix it :) )

My sign in url is pointing to a non existent path "/home/XXXXXX/public_html/people.php" instead of "mywebsite.com/people.php", i am not able to find the fix for this. I hope this is a generic question applying to other versions also and hence still useful to community.

Thanks in advance for your help.

Tagged:

Comments

  • Almost no-one is using vanilla 1. I doubt you will get support for it.

    Only a couple of developers worked on it, one of which no longer works for the company.

    Vanilla 1 is part of the distant past. It is a historical curiosity, it have virtually no relation to Vanilla 1 other than perhaps a basic concept.

    grep is your friend.

  • i guess mentioning version was an unnecessary digression. If the fix applies to all versions it should be helpful to all version, unless i am wrong...

  • R_JR_J Ex-Fanboy Munich Moderator
    edited September 2015

    Maybe it has to do with your htaccess file? Try RewriteBase /


  • peregrineperegrine MVP
    edited September 2015

    @scotty said:
    i guess mentioning version was an unnecessary digression. If the fix applies to all versions it should be helpful to all version, unless i am wrong...

    maybe, maybe not.

    since you are using vanilla 1.5.1 (I don't think anyone would jump on you for changing the core files, since you probably did, other wise you would have upgraded).

    if it aint broken why fix it :) )

    :grin: conversely if it is broke (and may have security issues), upgrade it.

    even more curious, if the signin url doesn't work, how could anyone have ever signed in? :grin::grin:

    you could certainly add debug here with echo or var_dump. and you could probably hard code if push came to shove.

    https://github.com/vanilla/vanilla1/search?utf8=✓&q=signin

    did you check your CONFIGURATION of WEBROOT and SIGNIN_URL

    quite an old version of jquery.

    are you still using DOS 1.0 or CP/M or an Altair or Commodore computer with Arcnet network as well?

    http://www.vanilla1forums.com/demo/

    https://code.google.com/p/lussumo-vanilla/

    maybe you could ask subjunk...

    http://www.spirton.com/vanilla-1/

    https://github.com/vanilla/vanilla1/commit/57646019ee900fa04df5f6a2b92ac2c2502ef051

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

  • @scotty , what is up with the duplicate posts?
    http://vanillaforums.org/discussion/30851/how-to-change-sign-in-url#latest
    I would upgrade to another version. I cannot imagine the dangerous security risks. Remember, these are other people you are putting in danger, not just your company.

  • @peregrine Thanks for the suggestions, you are right, i did end up modifying certain core files and hence stuck with it. Wish i had more time on my hand to check all changes and upgrade .. sigh.
    It used to work, i switched hosting, faced some bugs, ended up get everything working except this! (as mentioned i dont spend as much time as i would like to on this) Will check your suggestions for the fix and update.
    @ytadvisors point taken, Thanks. will keep in mind and add upgrade in plan

  • @ytadvisors i wanted to delete my initial post (this one) and repost modified version. But i could not find a way to delete my post. Apologize for spamming, didnt mean to.

  • @scotty said:
    ytadvisors i wanted to delete my initial post (this one) and repost modified version. But i could not find a way to delete my post. Apologize for spamming, didnt mean to.

    No worries, just wondering why you created 2 posts.

  • configuration SIGNIN_URL was missing from settings.php ... :o Thanks for all helpful comments.

    hgtonight
Sign In or Register to comment.