Please upgrade here. These earlier versions are no longer being updated and have security issues.

Can't sign in or out after new install.

Installed Vanilla 2.2 on Ipage hosted server. Everything looks as if it works after install but can't sign in or sign out. When clicking to sign out or in, I get.

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, and inform them of the time the error occurred, and anything you might have done that may have caused the error.
More information about this error may be available in the server error log.

One install I uploaded the files myself through filezilla.
http://scripturehousepublications.org/forum/index.php?p=/

The other install I used ipages Mojo Market script and let them do the DB and everything else.
http://scripturehousepublications.org/van/index.php?p=/

Both sites do the same thing, I can't sign in our out but all other navigation seems to work just fine. I messed with no other options in the default install.

To make sure it was not something with Ipages, I installed mybb to see if there were issues with sign in or out and it works fine out of the box.
http://scripturehousepublications.org/cvb/

I want to eventually connect the forum to my WP blog and both forums seem to have that options, but mybb needs my ipage host to have PHP Runkit in the root directory and even after trying to follow instructions, I have no idea what the heck they are talking about to make that happen and Vanilla won't let me sign in or out.

Thank you for any help.

Tagged:

Comments

  • I contacted my host to track down the error. This is the conversation.

    Anupam S: I check with our engineers and they confirmed, its scripting issue and request you to debug script from your end to fix it.
    Anupam S: Error logs: PHP Parse error: syntax error, unexpected '[' in /hermes/bosnaweb03b/b1842/ipg.wolpuborg/van/applications/dashboard/controllers/class.entrycontroller.php on line 400
    Mike: I am a noob. I assume that is a file in my vanilla folder correct?
    Anupam S: Path is /van/applications/dashboard/controllers/
    Mike: Thank you for the help. I might have to take this information to vanilla forums.
    Anupam S: Sure.
    Anupam S: You're welcome!
    Anupam S: If you are happy with my support, please grade me 9 or 10 by clicking on the “Rate & Exit” button on the top right corner of this chat window. In case my support did not meet your expectation, please let me know the reason.
    Mike: Ok.

    The File: class.entrycontroller.php
    398 // Filter the form data for users here. SSO plugins must reset validated data each postback.
    399 $filteredData = Gdn::userModel()->filterForm($currentData, true);
    400 $filteredData = array_replace($filteredData, arrayTranslate($currentData, ['TransientKey', 'hpt']));
    unset($filteredData['Roles'], $filteredData['RoleID']);
    $this->Form->formValues($filteredData);

    All Klingon to me, All I know is Mybb works and Vanilla does not. Any help would be appreciated.

  • peregrineperegrine MVP
    edited November 2015

    try the stable vanilla version 2.1.13p1

    or upgrade your php to the proper version of php required.

    http://vanillaforums.org/discussion/31046/vanilla-2-1-13-security-updates

    if you are using a version of php lower than 5.4 or higher and using master version, you are not carefully reading installation instructions and requirements.

    if you are using a version of php lower than 5.3 or higher and using master version, you are not carefully reading installation instructions and requirements.

    if you are not a developer, and things are klingon, it is not wise for you to use alpha or beta or rc versions of vanilla, and you should stick to to the stable version.


    there appears to be a bug in vanilla 2.2rc1

    https://github.com/vanilla/vanilla/blob/release/2.2/applications/dashboard/controllers/class.entrycontroller.php#L400

    php 5.3 does not support....

    $filteredData = array_replace($filteredData, arrayTranslate($currentData, ['TransientKey', 'hpt']));

    it needs to be....

    $filteredData = array_replace($filteredData, arrayTranslate($currentData, array('TransientKey', 'hpt')));


    • short array requires php 5.4 and vanilla 2.2rc1 supports php 5.3 which does not support short array syntax.
    • line 400 in 2.2rc1 as of today is $filteredData = array_replace($filteredData, arrayTranslate($currentData, ['TransientKey', 'hpt']));
    • short array syntax [] is supported in PHP 5.4 or higher.
    • while vanilla 2.2rc1 requires 5.3

    http://php.net/manual/en/migration54.new-features.php

    vs.

    http://php.net/manual/en/migration53.new-features.php

    I may not provide the completed solution you might desire, but I do try to provide honest suggestions to help you solve your issue.

    hgtonight
  • @peregrine said:
    try the stable vanilla version 2.1.13p1

    or upgrade your php to the proper version of php required.

    http://vanillaforums.org/discussion/31046/vanilla-2-1-13-security-updates

    if you are using a version of php lower than 5.4 or higher and using master version, you are not carefully reading installation instructions and requirements.

    if you are using a version of php lower than 5.3 or higher and using master version, you are not carefully reading installation instructions and requirements.

    if you are not a developer, and things are klingon, it is not wise for you to use alpha or beta or rc versions of vanilla, and you should stick to to the stable version.


    there appears to be a bug in vanilla 2.2rc1

    https://github.com/vanilla/vanilla/blob/release/2.2/applications/dashboard/controllers/class.entrycontroller.php#L400

    php 5.3 does not support....

    $filteredData = array_replace($filteredData, arrayTranslate($currentData, ['TransientKey', 'hpt']));

    it needs to be....

    $filteredData = array_replace($filteredData, arrayTranslate($currentData, array('TransientKey', 'hpt')));


    • short array requires php 5.4 and vanilla 2.2rc1 supports php 5.3 which does not support short array syntax.
    • line 400 in 2.2rc1 as of today is $filteredData = array_replace($filteredData, arrayTranslate($currentData, ['TransientKey', 'hpt']));
    • short array syntax [] is supported in PHP 5.4 or higher.
    • while vanilla 2.2rc1 requires 5.3

    http://php.net/manual/en/migration54.new-features.php

    vs.

    http://php.net/manual/en/migration53.new-features.php

    Wow, that line of code worked!! I had no idea I had installed the wrong version for my Host "Ipages" I doubt I would get them to update their PHP just for me, and they won't install PHP runkit for me either as they don't allow SSH Access. (Could be why it's 1.99 month)

    Though I am not a coder, your line of code worked for me and I can sign in and out. Now I hope to get the WP and Vanilla integration working since it's the open source Vanilla. Mybb would have worked, but it needs the PHP Runkit Ipage won't install for me or allow me to do it.

    Thank you for the amazing help. I hope I don't run into any more PHP related issues, but everything else seems to be working fine. If I do, I will just install the other version of Vanilla.

    Mike.

Sign In or Register to comment.