Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Issues Upgrading to 2.2

edited November 2015 in Vanilla 2.0 - 2.8

What I've done:

  • Copy my live site to a new folder
  • Copy my database and repoint the new site to the new database
  • Test the new site (everything is working)
  • Unzip vanilla 2.2 over the new site

Now when I navigate to the new site, I'm getting a 500 error. Digging into my apache logs, I see the following:
Call to a member function HasNewMethod() on a non-object in /var/www/old site/library/core/class.pluggable.php on line 188

I'm guessing I need to change a setting somewhere to repoint vanilla to my new site?


  • Options
    whu606whu606 I'm not a SuperHero; I just like wearing tights... MVP


    Have you followed all the steps here:

    Particularly, have you deleted the ini files from your cache folder?

  • Options

    Many thanks! Clearing out the cached .ini files did the trick!

    Also, thanks for passing along the link. I'll definitely be following the steps for future upgrades :)

  • Options

    So everything went fine in my staging environment, but I ran into an issue after deploying 2.2 to my live site.

    For the most part, everything seems to have worked. Users are able to browse the site, post etc... I am able to do all my regular stuff on the dashboard. The only problem, is when I try and manage my categories, I redirect to the following URL and an error message is displayed:

    Some of your folders do not have the correct permissions.

    Using your ftp client, or via command line, make sure that the following permissions are set for your vanilla installation:

    chmod -R 777 /var/www/sitename/vanilla/conf
    chmod -R 777 /var/www/sitename/vanilla/uploads
    chmod -R 777 /var/www/sitename/vanilla/cache

    I have ensured that the permissions on those folder are set correctly. Not sure where to go next with this?

  • Options

    I re-verified the permissions... I must have missed something previously, because I am no longer receiving a permissions error. However, I am still being redirected to /vanilla/index.php?p=/dashboard/setup when I click on Forum>Categories or Forum>Advanced from the dashboard.

  • Options
    vrijvlindervrijvlinder Papillon-Sauvage MVP

    Your htaccess file needs fixing, I would reupload the file via ftp and make sure the htaccess file is pointing to the right place etc.

    If you are being sent to a setup page something may be funky with the config.php

  • Options

    Thanks, I will take a look when I get home from work. Is there any way to generate a "fresh" config.php? If I follow the setup with my existing details, is there any risk of damage to my existing database?

  • Options

    So, my staging site is still working... so I tried to copy the .htaccess file and config.php file from there, and I'm still having issues with the 2 admin sections.

    Only Forum>Categories and Forum>Advanced, as well as Moderation>Flood Control are causing an issue. I seem to be able to modify anything else on the Dashboard without a problem.

    I also pointed the staging site to the live database, and am able to use all functions without problems.

Sign In or Register to comment.