Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

comment removal

edited August 2006 in Vanilla 1.0 Help
everything seems ok when i activate the addon "comment removal" but when im clicking on the "delete" link, i just have a popup telling : Error : nothing more ! no error message ! am i alone with this ?
«13

Comments

  • Options
    MarkMark Vanilla Staff
    It would probably be a good idea to put the extension author's name in your discussion topic. That way he/she will see it when they drop by.
  • Options
    oops sorry ! after checking : not much info on the author : Extension Name: Comment Removal Extension Url: http://lussumo.com/addons Description: Allows users to actually delete comments and discussions instead of merely hiding them. Version: 1.3 Author: SirNotAppearingOnThisForum Author Url: N/A
  • Options
    Sirnot is the author.
  • Options
    I have exactly the same problem as sabina. Comment removal was working perfectly until yesterday, when I installed additional add-ons. These are the ones I installed: Account Pictures 1.0 Extended Application Form 1 Markdown 0.1 FeedReader 0.3 After uninstalling the add-ons Comment removal was still not working, so there might be something else to this.
  • Options
    same problem as sabina
  • Options
    I have this problem in one installation of Vanilla but not in another that I'm testing in a different computer. My problem is that the version of MySQL that I have in the computer where it is not working is too old (see the comments of Sirnot in the extension description, it should be at least MySQL 4.1). But this does not help to explain the problem of kari.patila. Perhaps there is something more.
  • Options
    NickENickE New
    edited August 2006
    Ok, I completely rewrote the ajax side of it, sans sub-queries, and also fixed a few bugs here and there. Try it now (again, at your own risk) and see if it works.
  • Options
    :( still not working ive got a huge error msg but i don't know how to post a pic here :)
  • Options
    Select the message, copy it (Ctrl + v) and paste it (Ctrl + c) here.
  • Options
    i can't javascript alert :( here : www.autourdebeauvoir.net/truc.jpg
  • Options
    MarkMark Vanilla Staff
    edited August 2006
    image
  • Options
    I'm gonna assume you wiped out the previous extension and installed the update which sirnot said he'd done? If so it looks like you probably just need to open up ajax.php and change the top include('..\..\appg\settings.php'); line to include('appg\init_settings.php');. Might do the trick
  • Options
    NickENickE New
    edited August 2006
    Ah crud, I keep forgetting about those backslashes... I think it should work now, changed them to forward-facing slashes.
  • Options
    haha. I was a bit puzzled why they were backward but i didnt know it'd actually make any difference.
  • Options
    Still got the first message : Error : and nothing else :(
  • Options
    Hate to keep putting you through this, but I think I've fixed it, so could you try it again?
  • Options
    sure i will hum actually, it's strange i still got the error message Error : with nothing but if i go to categories and come back to discussions, the comment are not there so, i think it's already work i just don't understand the error message another question : why all the comments still showed on the first page ? started by sabina Comments 4 (but its suppose to be 0)
  • Options
    That was part of the error. It got to the part where it deleted the actual comment fine, but it was when it attempted to update the discussion information (comment count, last comment, etc...) that it ran into the error.
  • Options
    if you find any solution, let me know ! i will test :)
  • Options
    NickENickE New
    edited August 2006
    Now you're sure you keep getting errors with the latest update? Are the errors when you try to delete a comment or discussion? Whispered or not?
This discussion has been closed.