Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

[Bug] Two text fields appear instead of one.

RodSloanRodSloan New
edited January 2016 in Vanilla 2.0 - 2.8

Observed behaviour

I installed the plugin on my test forum and, instead of the one text field, now get two, both with TinyMCE.

Here's a screen shot:
Screen shot of the bug
One of the text fields is right at the bottom of the page.

Additionally, I can't post anything and recieve a "Body is required" message when I try to. This occurs even if I fill both fields. The post Preview button seems disabled (not the TinyMCE preview dropdown option, that works fine).

Version information

  • Forum is 2.2
  • Vanilla MCE is 1.0
  • Theme is Silicon 2.0.2
  • Tested in Firefox and Chrome

Tried

  • I toggled the Button Bar and Advanced Editor plugins (no change with them off or on).
  • Using the inspector, it seems the bottom textbox is part of the whole page, I can't select individual elements of the box or TinyMCE like I can with the first textbox.
  • Will try and install it on another forum and see if I get the same error, but would like to understand this more before I do.

Comments

  • I tested the plugin on another instellation of Vanilla 2.2 and had the same problem.

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... MVP

    This addon was uploaded 2 years ago, when 2.0 was the current Vanilla version, and has not been updated since, so may well not be compatible with Vanilla 2.2.

    Is there something it offers that the Advanced Editor doesn't?

  • Dr_SommerDr_Sommer Dr. of tender Programing ;) ✭✭

    Try the Advanced Editor!! It's AWESOME!! :sunglasses::+1:

  • Thanks @whu606 and @Dr_Sommer, I've tried advanced editor but what I'm specifically looking for is a way to hide the formatting (markdown or html) tags, which TinyMCE does. Any recommendations for that?

  • Dr_SommerDr_Sommer Dr. of tender Programing ;) ✭✭

    Hmm... if I understand you correctly, your'e looking for a WYSIWYG Editor? Thats exactly what Advanced Editor is!! You can select WYSIWYG, Markdown, BBCode, HTML etc. in the Plugin setup.. :+1:

    vrijvlinderhgtonight
  • Thank you for the help, if you hadn't said anything I would have gone _way_down the wrong path. I managed to find out why my Advanced Editor wasn't working, so now all I need to do is fix that issue and I'm good to go!

Sign In or Register to comment.