Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Quotes: CommentID Link appears as plain number in the quote?

phreakphreak Vanilla*APP (White Label) & Vanilla*Skins Shop MVP
edited February 2016 in Vanilla 2.0 - 2.8

Hi all,

My quotes shows a comment ID string since 2.2. I'm not sure if it's me that messed up somewhere or there is a bug.

The issue can be seen between the Username and the "said" text. It seems to be the "Comment ID" and appears already trough the Javascript function in the comment form once "Quote" is hitten. I used the version of Vanilla 2.2 and also tried the current version on Github.

Here is a screen. Anyone has an idea what goes wrong here?

The output looks like that (in my screenshot "schrieb", it's german):
<div class="QuoteAuthor">Username;1000682" said:</div>

Thank you,
phreak

  • VanillaAPP | iOS & Android App for Vanilla - White label app for Vanilla Forums OS
  • VanillaSkins | Plugins, Themes, Graphics and Custom Development for Vanilla
Tagged:

Comments

  • phreakphreak Vanilla*APP (White Label) & Vanilla*Skins Shop MVP
    edited August 2016

    Hi all, i still have this problem on my forums with Quotes 1.7 (retrieved from Github some months ago) and also 1.6.10 (retrieved from original Vanilla 2.2.1 download). I also tried Quotes 1.9 from Github but run into a Whitescreen because of some error in the class.plugins.quotes.php.

    So stuck with 1.7 now, the rendering of the username described runs into the problem above. There is no issue on Github regarding this behaviour and as Quotes 1.9 and Vanilla 2.3 are around the corner i don't want to confuse the ticketing system with my problem.

    Thanx for ideas!

    • VanillaAPP | iOS & Android App for Vanilla - White label app for Vanilla Forums OS
    • VanillaSkins | Plugins, Themes, Graphics and Custom Development for Vanilla
  • Could you try this plugin?
    https://vanillaforums.org/addon/nbbc-plugin

    That solved the problem for me.

    vrijvlinder
Sign In or Register to comment.