Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Trying to debug a database problem

I've been trying to debug a database problem (I get an "Something went wrong" page when doing db upgrade). I think it is related to the Pockets plugin (latetst from Github). Possible related problem: When I give a user a role with permissions for "Allow no ads" (Pockets) then this particular Pocket is hidden, when I downgrade the user to a role that does not have permissions for "Allow no ads" then the ads are still not shown for that user.

See screenshot, is it normal for a RoleId to have multiple records in the permissons table ?


  • Options
    R_JR_J Ex-Fanboy Munich Admin

    Simple spoken: yes, roles can have different permssions.

    You see the junction column is null in the first line. Those permissions are Vanilla wide settings like Garden.SignIn.Allow which determines if a role is a guest role or not.
    Then you have the junction table Category so this line is for category permissions. The junctions ID in this case means that you are looking at the common category settings of this role.
    The last line is a hint that you have a custom permission for your category 20.

  • Options

    Thnx for the explanation. I've set debug to "true" but I still get the "Something went wrong" page. I'd like to see the actual sql error.

  • Options
    R_JR_J Ex-Fanboy Munich Admin

    "Something went wrong" doesn't have to be a db error. Do you have set $Configuration['Debug'] = TRUE; in your /conf/config.php?

  • Options

    thnx @R_J i had the debugger plugin set to true, not the 'Debug' line.

Sign In or Register to comment.