Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Fatal error after uploading vanilla to the server

samsam
edited August 2007 in Vanilla 1.0 Help
I have installed and configured VANILLA on my local pc and then transferred it via FTP to my server in the internet. I have also uploaded the 14 tables into the mysql datebase there. after calling VANILLA there I get this error: Fatal error: Cannot instantiate non-existent class: context in /raid/domains/com/m/meinebiografie/htdocs/doerren/forum/appg/init_vanilla.php on line 42 I personally think it has to do with maybe wrong path names etc. So I changed in the settings.php the paths like this: // Application Settings $Configuration['SETUP_TEST'] = '1'; $Configuration['APPLICATION_PATH'] = 'http://doerren.meinebiografie.com/forum/'; $Configuration['DATABASE_PATH'] = 'http://doerren.meinebiografie.com/forum/conf/database.php'; $Configuration['LIBRARY_PATH'] = 'http://doerren.meinebiografie.com/forum/library/'; $Configuration['EXTENSIONS_PATH'] = 'http://doerren.meinebiografie.com/forum/extensions/'; $Configuration['LANGUAGES_PATH'] = 'http://doerren.meinebiografie.com/forum/languages/'; $Configuration['THEME_PATH'] = 'http://doerren.meinebiografie.com/forum/themes/vanilla/'; $Configuration['DEFAULT_STYLE'] = '/forum/themes/vanilla/styles/default/'; $Configuration['WEB_ROOT'] = '/forum/'; $Configuration['BASE_URL'] = 'http://doerren.meinebiografie.com/forum/'; $Configuration['FORWARD_VALIDATED_USER_URL'] = 'http://doerren.meinebiografie.com/forum/'; $Configuration['SUPPORT_EMAIL'] = 'doerren@meinebiografie.com'; $Configuration['SUPPORT_NAME'] = 'Achim Samwald'; $Configuration['APPLICATION_TITLE'] = 'Forum Dörren'; $Configuration['BANNER_TITLE'] = 'Die gesunde Art Sonne zu speichern'; $Configuration['COOKIE_DOMAIN'] = 'localhost'; $Configuration['COOKIE_PATH'] = '/forum/'; $Configuration['SETUP_COMPLETE'] = '1'; and so on... But it is still not enough and by the way what becomes "localhost" on the server then? Can this be a hint on wrong database names / paswords etc? Any fast and useful is much appreciated. Thank you very much HANS

Comments

  • Options
    $Configuration['COOKIE_DOMAIN'] needs to be "http://doerren.meinebiografie.com"

    but there's something else wrong. i would re-upload all your vanilla files, and make sure you're using ASCII mode in your FTP client.
  • Options
    edited August 2006
    change your paths by:

    $Configuration['APPLICATION_PATH'] = '/raid/domains/com/m/meinebiografie/htdocs/doerren/forum/';
    $Configuration['DATABASE_PATH'] = '/raid/domains/com/m/meinebiografie/htdocs/doerren/forum/conf/database.php';
    $Configuration['LIBRARY_PATH'] = '/raid/domains/com/m/meinebiografie/htdocs/doerren/forum/library/';
    $Configuration['EXTENSIONS_PATH'] = '/raid/domains/com/m/meinebiografie/htdocs/doerren/forum/extensions/';
    $Configuration['LANGUAGES_PATH'] = '/raid/domains/com/m/meinebiografie/htdocs/doerren/forum/languages/';
    $Configuration['THEME_PATH'] = '/raid/domains/com/m/meinebiografie/htdocs/doerren/forum/themes/vanilla/';
  • Options
    MarkMark Vanilla Staff
    Yeah - your path variables are meant to be local system-specific paths, not url paths.
  • Options
    thanx a lot for all your ideas I have uploaded the files again my paths look now like this, but the trouble remains: <?php // Application Settings $Configuration['SETUP_TEST'] = '1'; $Configuration['APPLICATION_PATH'] = '/forum/'; $Configuration['DATABASE_PATH'] = '/forum/conf/database.php'; $Configuration['LIBRARY_PATH'] = '/forum/library/'; $Configuration['EXTENSIONS_PATH'] = '/forum/extensions/'; $Configuration['LANGUAGES_PATH'] = '/forum/languages/'; $Configuration['THEME_PATH'] = '/forum/themes/vanilla/'; $Configuration['DEFAULT_STYLE'] = '/forum/themes/vanilla/styles/default/'; $Configuration['WEB_ROOT'] = '/forum/'; $Configuration['BASE_URL'] = 'http://doerren.meinebiografie.com/forum/'; $Configuration['FORWARD_VALIDATED_USER_URL'] = 'http://doerren.meinebiografie.com/forum/'; $Configuration['SUPPORT_EMAIL'] = 'doerren@meinebiografie.com'; $Configuration['SUPPORT_NAME'] = 'Achim Samwald'; $Configuration['APPLICATION_TITLE'] = 'Forum Dörren'; $Configuration['BANNER_TITLE'] = 'Die gesunde Art Sonne zu speichern'; $Configuration['COOKIE_DOMAIN'] = 'http://doerren.meinebiografie.com/'; $Configuration['COOKIE_PATH'] = '/forum/'; The strange thing is the forum runs perfect on my local pc! Still any ideas?
  • Options
    edited August 2006
    you need absolute path for your *_PATH setting. Supposing the absolute path to your docroot is "/raid/domains/com/m/meinebiografie/htdocs/doerren/" and that vanilla is in the forum/ folder, just replace:
    $Configuration['APPLICATION_PATH'] = '/forum/'; $Configuration['DATABASE_PATH'] = '/forum/conf/database.php'; $Configuration['LIBRARY_PATH'] = '/forum/library/'; $Configuration['EXTENSIONS_PATH'] = '/forum/extensions/'; $Configuration['LANGUAGES_PATH'] = '/forum/languages/'; $Configuration['THEME_PATH'] = '/forum/themes/vanilla/';
    by$Configuration['APPLICATION_PATH'] = '/raid/domains/com/m/meinebiografie/htdocs/doerren/forum/'; $Configuration['DATABASE_PATH'] = '/raid/domains/com/m/meinebiografie/htdocs/doerren/forum/conf/database.php'; $Configuration['LIBRARY_PATH'] = '/raid/domains/com/m/meinebiografie/htdocs/doerren/forum/library/'; $Configuration['EXTENSIONS_PATH'] = '/raid/domains/com/m/meinebiografie/htdocs/doerren/forum/extensions/'; $Configuration['LANGUAGES_PATH'] = '/raid/domains/com/m/meinebiografie/htdocs/doerren/forum/languages/'; $Configuration['THEME_PATH'] = '/raid/domains/com/m/meinebiografie/htdocs/doerren/forum/themes/vanilla/';
  • Options
    Can't you transfert your database, make on update installation and upload extensions/ and conf/extension.php ?
  • Options
    That's the message I received when I changed to absolute paths: Warning: ini_set, ini_alter, ini_restore, diskfreespace, disk_free_space, exec, passthru, system, popen() has been disabled for security reasons in /raid/domains/com/m/meinebiografie/htdocs/doerren/forum/appg/headers.php on line 26 A fatal, non-recoverable error has occurred Technical information (for support personel): Error Message An error occurred while retrieving discussions. Affected Elements DiscussionManager.GetDiscussionList(); The error occurred on or near: Table 'com1173029.LUM_Discussion' doesn't exist For additional support documentation, visit the Lussumo Documentation website at: lussumo.com/docs
  • Options
    edited August 2006
    ini_set() is not allow by your provider. add "//" (or a "@) in appg/headers.php at the start of the line 26:
    @ini_set('session.use_only_cookies', 1);
  • Options
    thanks a lot Dinoboff, after your suggestions I now receive: A fatal, non-recoverable error has occurred Technical information (for support personel): Error Message An error occurred while retrieving discussions. Affected Elements DiscussionManager.GetDiscussionList(); The error occurred on or near: Table 'com1173029.LUM_Discussion' doesn't exist For additional support documentation, visit the Lussumo Documentation website at: lussumo.com/docs
  • Options
    edited August 2006
    Vanilla can't find the Tables. You have to edit conf/data.php, these setting:
    $Configuration['DATABASE_HOST'] = 'localhostUsually'; $Configuration['DATABASE_NAME'] = 'LoginNameUsually'; $Configuration['DATABASE_USER'] = 'YourLoginName'; $Configuration['DATABASE_PASSWORD'] = '**********';
  • Options
    I have had the same problem. On my localhost (windows) everthing works fine. Then I've uploaded all the files (incl. MySQL data)...the same error (The error occurred on or near: Table 'username.LUM_Discussion' doesn't exist ) appeared. Now I've found out, that the required tables are named like that: lum_tablename. However: The script needs tables named that way: LUM_TableName. Is there any possibilty to change this to case non sensitve? I don't know how to name the tables in the right way. i.e.: lum_disscussionviews becomes LUM_discussionviews, but some other tables are named like that: lum_categoryblock => LUM_Category_Block hope somebody has a solution :) thanks in advance!
  • Options
    Windows file system in not case sensitive, the unix one is. That's why mysql dump your Table name in lower case.

    You have 3 solutions:
    1. reinstall with a fresh DB.
    2. Rename your table names in PhpMyAdmin
    3. Or copy$Configuration['DATABASE_TABLE_PREFIX'] = 'LUM_'; $DatabaseTables['Category'] = 'Category'; $DatabaseTables['CategoryBlock'] = 'CategoryBlock'; $DatabaseTables['CategoryRoleBlock'] = 'CategoryRoleBlock'; $DatabaseTables['Comment'] = 'Comment'; $DatabaseTables['Discussion'] = 'Discussion'; $DatabaseTables['DiscussionUserWhisperFrom'] = 'DiscussionUserWhisperFrom'; $DatabaseTables['DiscussionUserWhisperTo'] = 'DiscussionUserWhisperTo'; $DatabaseTables['IpHistory'] = 'IpHistory'; $DatabaseTables['Role'] = 'Role'; $DatabaseTables['Style'] = 'Style'; $DatabaseTables['User'] = 'LUM_User'; $DatabaseTables['UserBookmark'] = 'UserBookmark'; $DatabaseTables['UserDiscussionWatch'] = 'UserDiscussionWatch'; $DatabaseTables['UserRoleHistory'] = 'UserRoleHistory'; into conf/database.php and change the case there. (that is for care table, you might have to do the same for extension table)
This discussion has been closed.