Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product
Please upgrade here. These earlier versions are no longer being updated and have security issues.

[jsConnect/SSO] - Unspecified Fatal Error on Activation

Good morning all,

I've just installed 2.2 - it's completely clean so far. I found that I can't use the handy Vanilla SSO plugin for WordPress because I'm on a shared server, so there's the whole loopback issue. So, doing it the long way. When I try to enable the jsConnect addon, though, it gives me a fatal error without actually showing me any specific error message.

I've searched the forum and Google at large and found that the recommended solution to a fatal error on enabling jsConnect is to upgrade to PHP 5.4 or newer. After a moment's excitement at finding such an easy fix, I remembered I'm running 5.5. Can anyone give me some guidance on this one?

Many thanks!
-Dev

Comments

  • Add $Configuration['Debug'] = true; to your conf/config.php and report back.

    This should give you a more specific error message.

    My themes: pure | minusbaseline - My plugins: CSSedit | HTMLedit | InfiniteScroll | BirthdayModule | [all] - PM me about customizations

  • Thanks for the quick response! No luck getting it to give me an error message. The way it appears, though, it looks like the forum software just has some styling issues that are preventing the error message from showing up. I viewed the page source and found reference to this: "TransportError":"A fatal error occurred while processing the request.

    It goes on to list a transient key and mention my WebRoot software. Tried going around WebRoot and got nowhere. A search for "transport error" just takes me to the same places I've already been, where the answer was to upgrade the PHP version.

  • So jsconnect can't even be enabled?
    Can other plugins be enabled? What version of jsconnect are you using?

    My themes: pure | minusbaseline - My plugins: CSSedit | HTMLedit | InfiniteScroll | BirthdayModule | [all] - PM me about customizations

  • Right, the fatal error happens when I try to enable it. Other plugins can be enabled without a problem.

    I'm using version 1.5.3, as found here.

  • I reinstalled it just now, and the error message in the source code is now much shorter:

    <li>The addon could not be enabled because it generated a fatal error: <pre>%s</pre></li>

  • You can try to force-enable it by adding this to your config:
    $Configuration['EnabledPlugins']['jsconnect'] = true;

    But if you can't enable a plugin, despite meeting the requirements, your hoster may not support some feature of it.

    My themes: pure | minusbaseline - My plugins: CSSedit | HTMLedit | InfiniteScroll | BirthdayModule | [all] - PM me about customizations

Sign In or Register to comment.