Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Failed to authenticate your password reset request. [RESOLVED]

amackleyamackley New
edited April 2016 in Vanilla 2.0 - 2.8

None of my users can reset their password. When logging in, if they try to sign in, click the "Forgot" link, and then enter their email or username, they will get an email link. (So the email process is working.) But clicking the link brings up the following error:

Debug Trace
Info FormattedMessage: anonymous failed to authenticate password reset request.

context: array (
'event' => 'password_reset_failure',
'userid' => 0,
'username' => 'anonymous',
'ip' => '',
'timestamp' => 1460497728,
'method' => 'GET',
'domain' => '',
'path' => 'entry/passwordreset/6/HWQ536fYDHumoZt8mvFG',


  • Here is another for my test user:

    context: array (
    'event' => 'password_reset_failure',
    'userid' => '2',
    'username' => 'amackley',
    'ip' => '',
    'timestamp' => 1460498335,
    'method' => 'GET',
    'domain' => '',
    'path' => 'entry/passwordreset/6/HWQ536fYDHumoZt8mvFG',

  • vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited April 2016

    Ok, please post the contents of your htaccess file and also if you have the bellow configuration in your config.php , if not then add it and make sure the rewrite base in the htaccess file does not have a # in front of Rewrite base /

    $Configuration['Garden']['RewriteUrls'] = TRUE;

    clear the .ini files in the cache and then report back if it helped the issue. Also under 2.2 User number 2 is supposed to be the Bot called System …

  • vrijvlinder, Thanks for the input.

    I'm not sure I got everything correct. First, I'm not sure what the "bellow configuration" is. I did open the config.php. Under Garden, I did not find a line for $Configuration['Garden']['RewriteUrls'] = TRUE;. I added it into the config.php in the conf folder.

    As for the htaccess file, I'm assuming you mean the .htaccess file in the root folder (where the index.php is located.

    This is the current content:


    If you modify this file then change the above line to: # Modified

    RewriteEngine On
    # Certain hosts may require the following line.
    # If vanilla is in a subfolder then you need to specify it after the /.
    # (ex. You put Vanilla in /forum so change the next line to: RewriteBase /forum)
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteRule ^(.*)$ index.php\?p=$1 [QSA,L]

    Afterwords, in the browser, I cleared all history, including browser history, downloaded images and files, cookies. I assume that clears the .ini files in the cache.

    Regarding user number 2, I think I moved from one browser to another, where I had already logged on as a different user. When I retested after these updates, I got a message similar to the first one.

  • I should note. It is still not solving the problem.

  • vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited April 2016

    It could be that the changes need to be refreshed and the issue is a cache problem.
    Please delete the .ini files in the cache of the forum.

    Make sure you entered the forum email in the email settings in the dashboard.

  • vrijvlinder. Thanks for your continued help. Still having trouble.

    I deleted all .ini files in /cache folder. Then I cleared my browser cache as well.
    Then I submitted a "Request a new password"
    I clicked the link from the email but still got the same error.
    Oh, I also updated the outgoing email address. I presume that is what you meant by email settings:

  • Update. It appears that it is now working. I think there may have been a delay in the system sending the email. I got a later email notification with a link, and it let me reset the password.

    For now, I am considering this issue resolved.


  • How do I mark my discussion as resolved and closed?

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... MVP

    I'll add [RESOLVED] to the title.

Sign In or Register to comment.