Please upgrade here. These earlier versions are no longer being updated and have security issues.

Dashboard User Registration Settings Basic Method problem

ProsperProsper ✭✭
edited April 2016 in Vanilla 2.0 - 2.8

I setup the dashboard - User Registration Settings to Basic but some prospective forum users cannot register because the registration page they see on their browser is that of "Approval - New users are reviewed and approved by an administrator (that's you!). They also see the statement "Why do you want to join".
I cannot understand why Approval registration method showed up whereas I setup Basic registration.
I need assistance to solve this abnormality.

Comments

  • Can someone please help me out on this problem.

  • Check your conf/config.php file if $Configuration['Garden']['Registration']['Method'] is set to "Captcha"

  • Yes I checked. It was set to "Captcha" but I have changed it to "Basic" to disable reCaptcha.
    However, approval registration method shows up to some prospective members while basic registration shows up to others.

  • TimP4wTimP4w New
    edited April 2016

    Sorry, I tried one more time and I'm not getting your results, but it seems like a caching issue from what you wrote.

    Now I'm not an expert and I don't know how Vanilla caching works and if that could be related to your problem, but try with deleting all the *.ini files in www/cache.

  • kopnakopna Coimbra Portugal ☯

    @Prosper написал:
    Can someone please help me out on this problem.

    You need to change the following in config.php:
    $Configuration['Garden']['Registration']['Method'] = 'NoCaptcha';

    good luck, ;)

  • @TimP4w and @kopna - Thanks for your comments. I have deleted the ini files and changed config to 'NoCaptcha' but problem persisted.

    When forum registration method is set to "Basic" and user fills all registration fields on registration page and click on the "sign up" button, a red background warning alert appears telling user to "Tell us why you want to register?". Also the entry field for why you want to register also appears. When user fills the field and once again click on sign up button, - thank you message for registration and that admin will have to approve your registration appears.

    So it is very strange since the forum is set to register user on BASIC and not APPROVAL.

  • @Prosper Can you please send me your forum URL by PM? I'm curious and I want to have a look at it.

  • ligyxyligyxy New
    edited April 2016

    @kopna What's the difference between NoCaptcha and Basic?

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    You are also using another plugin called BotStop or something like that ?
    What is the sum of 1+1 ?

    In that case , the plugin might be using a modified version designed to be used with Approval registration settings only.

    I suggest you either disable that plugin and then choose Basic registration with Captcha or you will get lots of spam.

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator

    @vrijvlinder said:
    What is the sum of 1+1 ?

    That's 2! image


  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    @R_J said:

    @vrijvlinder said:
    What is the sum of 1+1 ?

    That's 2! image

    I was not asking, that is their captcha question on the registration form for their website. They must be using BotStop or similar one which is likely set to work only with Approval… or something like that.

  • ProsperProsper ✭✭
    edited April 2016

    @vrijvlinder - There are three addons working on the registration page.

    1. Add Registration Question - that's the addon that shows the "what is the sum of 1+1? =)
    2. EmailVerify - This addon adds verify email field in other to avoid email typo - @peregrine helped me to develop this addon.
    3. RemoveTerm - This addon disables "I agree to the terms of service" - @peregrine helped me to develop this addon too.

    I am not sure if any of these plugin is set to work only on Approval. I can PM you their zip file for you to take a look. Thank you.

  • vrijvlindervrijvlinder Papillon-Sauvage MVP

    Please try disabling those plugins and then deleting the .ini files in the cache

  • ProsperProsper ✭✭

    Problem has been solved.
    Old plugin "stop forum spam" was the culprit.
    Thank you all for your assistance.

    vrijvlinderTimP4whgtonight
  • squallesqualle New
    edited August 2016

    I'm having this original issue. I set registration to Approval. When someone tries to sign up, the message "To use reCAPCHA you must get an API key from ..."

    The same thing happens with Basic.

  • vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited August 2016

    @squalle said:
    I'm having this original issue. I set registration to Approval. When someone tries to sign up, the message "To use reCAPCHA you must get an API key from ..."
    The same thing happens with Basic.

    How hard can it be to get get a captcha key from google ?

    This has nothing to do with your problem. Captcha is required for Basic registration. It also is required for Approval because it allows anyone to fill out the registration form.

    If you want to not use these, use invitation registration. That way you send them a number and they register without captcha.

    Captcha is important because your forum can become a spam heaven…for spam bots, then you will have issues deleting the millions of spam posts.
    Get a grip !!!

  • R_JR_J Cheerleader & Troubleshooter Munich Moderator
    edited August 2016

    .


Sign In or Register to comment.