Please upgrade here. These earlier versions are no longer being updated and have security issues.

Workaround for when host does not allow 777 to be set?[Resolved ]

tgp1994tgp1994 New
edited June 2016 in Vanilla 2.0 - 2.8

I'd like to install Vanilla 2.2 on Sourceforge's Project Web service, however they do not allow chmod 777 to be set period. They do allow 775. Is there any way I can work around this limitation so Vanilla can install?

Best Answers

Answers

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... Moderator

    @tgp1994

    Are you sure you need 777?

    I thought 775 would be enough.

    tgp1994
  • @whu606 said:
    @tgp1994

    Are you sure you need 777?

    I thought 775 would be enough.

    Heh, am I sure? Vanilla sure seems to think so :p: I thought 775 would be enough too, but not according to the installer. I just want to know if I can work around it. Directories are already set to 775.

  • vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited June 2016

    You can make the conf folder 755 and the config.php 775 as well as the uploads 775 and the cache

    If you can't do that, I suggest you get a different host because all of the software like Vanilla and Wordpress etc require those permissions for configuration files.
    Someone else came around here recently asking the same thing. He ended up getting another host.

    tgp1994
  • @vrijvlinder said:
    You can make the conf folder 755 and the config.php 775 as well as the uploads 775 and the cache

    If you can't do that, I suggest you get a different host because all of the software like Vanilla and Wordpress etc require those permissions for configuration files.
    Someone else came around here recently asking the same thing. He ended up getting another host.

    OK, I have no problem setting permissions to 755/775 so Vanilla will still work then. How can I bypass this error message in the installer? Apparently it will not proceed unless it thinks the directories are set to 777.

  • vrijvlindervrijvlinder Papillon-Sauvage MVP
    edited June 2016

    How did you install Vanilla ? Please let us know the url of where the forum is supposed to be installed.

    The only option is to look at your files and how they are installed. you would need to give us your filezilla login info via private message to remotely see what is what is going on.

    Tell your host to set those folders to 777 temporarily until you finish the setup and then return them to 775 etc.

    The thing is that those folders need to be writable. So that the config.php gets created and populated.

  • @vrijvlinder said:
    How did you install Vanilla ? Please let us know the url of where the forum is supposed to be installed.

    The only option is to look at your files and how they are installed. you would need to give us your filezilla login info via private message to remotely see what is what is going on.

    Tell your host to set those folders to 777 temporarily until you finish the setup and then return them to 775 etc.

    The thing is that those folders need to be writable. So that the config.php gets created and populated.

    I installed it the normal way - downloaded Vanilla 2.2.1 release, uploaded to host, unzipped, and opened index.php. It seems to me that the installer expects permissions to be 777. I'm thinking at this point I'll just modify the installer the script so it doesn't require such generous permissions. The folders are writable, I can say that for sure.

  • Very nice explanation, thank you!

  • the only reason why any ever set 777 is poorly implemented generic cheap hosts, with no ability to set ownership.

    777 is just bad file management and laziness.

    The problem is people don't understand it is not just permission it is about ownership and groups.

    I don't even like when people use web applications manage their files, that is the tail wagging the dog.

    grep is your friend.

    tgp1994
Sign In or Register to comment.