Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Unable to view or edit individual forum posts but can see Recent Discussions

matt3006matt3006 New
edited July 2016 in Vanilla 2.0 - 2.8

I have been working on this for the past few hours and cannot seem to figure out why I am now having the problem of being able to view the Recent Discussion just fine, but cannot read/view/edit individual forum posts. In Firefox, I get a blank screen. In Chrome, I get HTTP Error 500. On my Android phone (Google Nexus 6 ), I also get the same errors with the respective browsers.

The live production site is:

I was able to add a Test message but can't do anything else with it.

I have tried to reinstall all new versions of Vanilla 2.2.0 and 2.2.1 on the same host with the same results.

Version 2.2.1

Version 2.2.0

There is only the default message and I cannot read/view/edit that one post. There are no plug-ins and it is the default theme. It doesn't get more barebone than that.

I have a suspicion that it is something at the webhost level (Bluehost) where I updated to a newer EasyApache 3 profile and/or updated the kernel through WHM. It was at stable PHP 5.5 and I updated it to latest stable PHP 5.6. I only did updates because I kept getting security error messages about using an older kernel and it motivated me to look at other possible updates. I have taken the PHP back down from PHP 5.6 to previous 5.5 thinking that was the problem but it hasn't worked.

I have also done a Graceful Server Reboot hoping it would clear up by itself but it has not.

I am clearly stumped and don't know where else to look. Can anyone give me some direction or insights? Thank you so much for any help you can give.


  • Options
    R_JR_J Ex-Fanboy Munich Admin
  • Options

    I called Bluehost to help me find the Error logs and I have multiple entries of this.

    ****[14-Jul-2016 05:54:15 UTC] PHP Fatal error: Call to undefined function mb_detect_encoding() in /home/matthhf5/public_html/restrainingorderdefense/forumtest/library/vendors/simplehtmldom/simple_html_dom.php on line 988****

    I will follow-up with the link you provided to see if I can pin it down further.

  • Options
    matt3006matt3006 New
    edited July 2016


    Thank you so much! That nailed it! It was the mbstring extenstion that needed to be added! The upside of this debacle is I am much more fluent on all the PHP options with WHM and EasyApache3.

    In the interest of passing it forward and helping others, I am NOT generally a "command line" guy. With my Bluehost VPS service, I had to muddle my way in WHM, go to Software, EasyApache 3, Basic Apache 2.4 build, Customize (the wheel icon), choose PHP 5.6.23, Exhaustive Options List (at the bottom of screen), then check the box Mbstring.

    Once all that is done, you click Save and Build and wait 15 minutes for the rebuild to occur.

    The upside is that I am now on PHP 5.6.23 which I was previously on PHP 5.5.37. So, I have extended the life of my current Apache build a tad longer.

    Vanilla forums is really growing on me. I really hope it continues to expand its capabilities. Overall, it has been easy to manage.

Sign In or Register to comment.