Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product

Ready to contribute?

Amazing! Sign our contributors' agreement and then join us on GitHub.

In vanilla forum, message time and post time is displayed wrong

In forum whenever anybody messages or posts something, the time is displayed wrong, it is showing half an hour back time. The default timezone is set as "UTC" and for India timezone is "UTC+05:30". I tried to change it to "UTC+05:30" and "Asia/Kolkata" but it didn't work. I think this function **date_default_timezone_set() **will not accept "UTC+05:30" but "Asia/Kolkata" is also not working for me.

Best Answer

Answers

  • RiverRiver MVP
    edited August 2016

    this issue has been reported many, many times. it is still an issue and has not been corrected.
    Vanilla 2.2.1 only supports timezones with 1 hour. support for only integer time zones.

    see for more info India Time

    Pragmatism is all I have to offer. Avoiding the sidelines and providing centerline pro-tips.

    vrijvlinderLuckyChauhan
  • edited August 2016

    @River thanks. I am new to vanilla forum.

  • whu606whu606 I'm not a SuperHero; I just like wearing tights... Moderator

    I don't see how you take

    We don't currently plan to implement this. I'd accept a pull request for it.

    as users being left out in the cold.

    Isn't the point of Open Source that users who want to can contribute to the code, rather than it all falling on the developers?

    Not sure what value there is in perpetuating a hostile attitude towards the dev team, for that matter.

    R_Jhgtonight
Sign In or Register to comment.