Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product
Vanilla 2.6 is here! It includes security fixes and requires PHP 7.0. We have therefore ALSO released Vanilla 2.5.2 with security patches if you are still on PHP 5.6 to give you additional time to upgrade.
Please upgrade to 2.3 here. The 2.2 and earlier branches are no longer being updated.

Strange problem with YAGA text

This discussion is related to the Yet Another Gamification Application addon.


you can see the problem in the image - a lot of the text comes up like this for forum users. (circled in blue)

I'm using Vanilla 2.2.1and YAGA 1.1

Any ideas?

yag.jpg 86.2K

Comments

  • RiverRiver MVP
    edited August 2016

    the translations are not occurring. Either your locale is not supported or you forgot to translate the definitions. are you using "en". look in the locales folder of the yaga app to see what defintions you have and determine which locale you are using.

    you can look in the ini files in the cache folder and see what locales you have loaded (see the ini file that has the word locale in it).

    also look in your config.php to see what locales you have enabled and what is the default locale.

    if none are set in config.php - it will use the default locale name from config-defaults.php
    which iirc is

    $Configuration['Garden']['Locale'] = 'en';

    reload the locales or delete your ini files.

    Pragmatism is all I have to offer. Avoiding the sidelines and providing centerline pro-tips.

    vrijvlinderhgtonight
  • RiverRiver MVP
    edited August 2016

    after you make sure you have the correct and updated locale files from yaga.
    copy the en-CA.php in the Yaga app to en.php

    then delete the ini files in your cache folder to reset locales.

    Yaga may be using the incorrect and deprecated locale for the english language. it should be en.php in Yaga/locale/en.php

    Pragmatism is all I have to offer. Avoiding the sidelines and providing centerline pro-tips.

    vrijvlinder
  • RiverRiver MVP
    edited August 2016

    you won't be able to change the text in the activity table, since that is water under the bridge, unless you manually edit the activity table for older entries. But once you fix the locale issue, the alltime leaderboard translations,etc the activities table should reflect the correct names.

    make sure the enabled locale has these 3 definitions.

    $Definition['Yaga.Rank.PromotedHeadlineFormat'] = '{ActivityUserID,You} earned a promotion to {Data.Name,text}.';
    $Definition['Yaga.LeaderBoard.Week'] = "This Week's Leaders";
    $Definition['Yaga.BestContent.AllTime'] = 'Best Content of All Time';

    you also may want to download Yaga again and make sure all the files from the locale folder are copied to your forum.

    and re-read the comments I posted.

    Pragmatism is all I have to offer. Avoiding the sidelines and providing centerline pro-tips.

    vrijvlinderRajio
  • RajioRajio
    edited August 2016

    Thanks @River.

    In /conf/config.php I've got
    $Configuration['Garden']['Locale'] = 'en';

    in /applications/yaga/locale I've got
    en-CA.php and have duplicated that as en.php
    (contents of both files look fine at a glance)

    I've deleted all ini files in /cache too

    Still no changes evident. Its strange.

  • Oh wait. never mind. you're right. that fixed it. i was seeing the old text in the activity table but yeah new text is appearing fine. Thanks @River! Case closed.

Sign In or Register to comment.